[Tutorial] How to install Virt-Manager Correctly on EOS/Arch base systems

It seems to be happening with eos live and installed VM. After loading eos fails to load DE graphical environment only mouse pointer gets loaded. Then I tried ArcoLinux with the same graphic settings and it worked. Might be due to Open GL. Would be grate if a dev could look into it.

3D enabled.

Arco Live Environment.

1 Like

@ricklinux

Have you tried gnome-boxes? I assume KDE also has a similar app.
Anyway, gnome-boxes is a wrapper around qemu as well, and it is quite easy to use.
I recently tried it, and seems to work well.

1 Like

I just installed eos BSPWM edition and it worked with 34 enabled. I’m testing KDE as we speak to see if this is got to do with the compositor. Because BSPWM has picom.

If KDE works I will check with Arco Linux XFCE. To see if it’s caused by XFCE generally or not.

No i haven’t tried it. But if KDE has something similar i could.

It is possible to install gnome-boxes to KDE…

Okay. Just using normal methods.

1 Like

Yes. And the guest system needs spice-vdagent package to make it work smoother.

I got i running but is only Bios mode?

Edit:
What do i need to install besides gnome-boxes?

On host it automatically takes all needed dependencies.
On guest the thing I mentioned above. You can do this while running the guest.

It was working better before i added stuff to conf files and added that package but only works on Bios.

So far I just tried it, but didn’t try any UEFI mode. And I’m not at my linux box right now, can’t check it either…

I don’t see any UEFI mode?

I’m not yet very familiar with gnome-boxes so I don’t know how to make it support UEFI mode, sorry…

Edit: found this: https://blog.agchapman.com/configuring-gnome-boxes-vms-using-virt-manager/

Yes…this looks much better. I think i uninstall Gnome boxes and try this way.
Edit: I guess you still need Gnome boxes installed?

Gnome boxes is just another wrapper, so it can be uninstalled.
But other wrappers will need mostly the same dependencies.

I actually like vmware workstation but i just need help figure out how to make the network connections work on here.

You mean with VMWare? doesn’t it work out of the box?

I’m going to load it again right now.

EDIT Made: Added a note mentioning the current issue with XFCE DE.

I decided i stick with virt-manager.