Trying to Install Endeavour OS, Boot Loader Failing to Install

Hey! So I’m mainly a Windows user looking to switch to EndeavourOS (I have experience with system administration) for Hyprland. I’ve tried to install EndeavourOS a couple of times but haven’t been able to do so no matter what I try.

First I had the Endeavour OS on Ventoy and tried installing (same error that will be shown below) but after it didn’t work, I tried just flashing my USB with the ISO. Same error regardless.

I have an empty partition on my SSD I want to install Endeavour too (Windows is installed as well, for reference) | But I don’t want to wipe the disk, since I want to dual boot and trying things out before proceeding with a full wipe.

Everytime I select “Replace my Partition” and set the boot loader to “System Partition, /”, I get this error regardless. I tried to manually create my partitions (with a 1GB grub-boot partition too), to no avail.

I have an extra HDD I can wipe to install Endeavour on. But I’d prefer the root file system be on my SSD, so I figured I’d ask here.

Here is the error I keep getting when attempting to install. Typically on the installing bootloader step:

The bootloader could not be installed. The installation command <pre>grub-install --target=i386-pc --recheck --force /dev/sdb5</pre> returned error code 1. for full log

I’ve tried literally everything I could find. Here is my hardware specs:

  Kernel: 6.7.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: KDE Plasma v: 5.27.10 Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: X470 GAMING PLUS (MS-7B79) v: 2.0
    serial: <superuser required> BIOS: American Megatrends LLC. v: A.L0
    date: 07/25/2022
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+
    rev: 2 cache: L1: 512 KiB L2: 4 MiB L3: 32 MiB
  Speed (MHz): avg: 3150 high: 4375 min/max: 2200/5584 boost: enabled cores:
    1: 2200 2: 4373 3: 4375 4: 2200 5: 2200 6: 2200 7: 4374 8: 4374 9: 4374
    10: 2200 11: 4358 12: 2200 13: 2200 14: 2200 15: 4375 16: 2200
    bogomips: 140048
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600]
    vendor: XFX driver: amdgpu v: kernel arch: RDNA-3 bus-ID: 29:00.0
  Device-2: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
    bus-ID: 5-4:4
  Display: server: X.Org v: 21.1.11 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
    1: 2560x1440~60Hz 2: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,radeonsi,swrast platforms:
    active: gbm,x11,surfaceless,device inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7600 (radeonsi navi33
    LLVM 16.0.6 DRM 3.56 6.7.1-arch1-1)
  API: Vulkan Message: No Vulkan data available.
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 29:00.1
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 2b:00.4
  Device-3: Plantronics RIG 800HD driver: plantronics,snd-usb-audio,usbhid
    type: USB bus-ID: 1-13:3
  Device-4: Audio-Technica ATR2100-USB
    driver: hid-generic,snd-usb-audio,usbhid type: USB bus-ID: 5-3:3
  Device-5: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
    bus-ID: 5-4:4
  API: ALSA v: k6.7.1-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 2.99 TiB used: 0 KiB (0.0%)
  ID-1: /dev/sda vendor: Western Digital model: WD20EZAZ-00L9GB0
    size: 1.82 TiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-3: /dev/sdc vendor: Toshiba model: MQ01ABD075 size: 698.64 GiB
  ID-4: /dev/sdd model: USB DISK 3.0 size: 29.47 GiB type: USB
  ID-1: / size: 10 GiB used: 843 MiB (8.2%) fs: overlay source: ERR-102
  Alert: No swap data was found.
  System Temperatures: cpu: 46.6 C mobo: N/A gpu: amdgpu temp: 31.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
  Processes: 366 Uptime: 13m Memory: total: 32 GiB available: 31.27 GiB
  used: 4.19 GiB (13.4%) Init: systemd Compilers: gcc: 13.2.1 Packages: 978
  Shell: Bash v: 5.2.26 inxi: 3.3.31

For reference, I installed NixOS on this same partition (now wiped) just fine. Switching to Endeavour as I dislike Nix’s complexities comparatively to what I need.

It’s not like it’s not creating the partition either. It’s fully made here (I tried to Encrypt it this one time, same issue when not encrypting)

Adding on even further:

I tried an install with the extra HDD I had. Same error.

It looks like you are trying to do a Legacy boot install into an EFI system.

The ISO can be booted in either Legacy or UEFI.

Try booting the ISO in UEFI mode from your BIOS.


Try a separate boot partition for linux, don’t use the windows one, afterwards in Bios use the linux one as primary boot partition.

1 Like

Looks like they are trying to install the bootloader (for legacy boot) to the same partition (/dev/sda5) as the root partition for EnOS on a GPT disk ?

1 Like

to check on LiveSession if it is booted in UEFI or Bios (CSM Legacy) mode you can run:
efibootmgr from a terminal … it will show boot entries if efi and an error message when booted in legacy mode…
So you need to disable legacy CSM Bios boot modes in your EFI-Firmware (Bios) to make sure ISO boots in EFI mode.

efi mode boot menu:

legacy boot MBR Bios CSM boot:

1 Like

Thank you for the help!! For future reference if anyone has this issue, for some reason systemd-boot didn’t work for me so I just installed with grub on the partition.

Thanks for the help :smiley:

if you where able to properly boot in uefi mode you would be able to have them both grub or systemd-boot…

I had, but it just didn’t work. Though it may have been due to something on my computer preventing it; but I booted into UEFI mode from BIOS and it’s set to do so now as well.

I didn’t receive an error, but I couldn’t boot into Endeavour from BIOS or from Windows Boot Manager (though I’m now running grub as my default boot manager)

would be cool to get the installer log… you can use eos-log-tool gui to send a pastebin and share the URL here.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.