Trying to Install EdeavourOS under VMWare

I am trying to install EndeavourOS under VMware, latest version.

I select EndevourOS default install, and after a while, it fails with a message falling back to interactive mode, after ERROR: /dev/disk/by-labels/EOS_202308 device did not show up after 30 seconds…

I cannot type on the console, so I couldn’t capture any logs. I am just booting from the ISO, untouched. The sha512 validates ok e8bffcf4a3b71dbf671a0dc64c4e186821ae4aca58545538c1c394f5a9578b8682a7598d825e66c9d581b97ab782ca4e317cc5dfa82edd968df00309ade3510a Endeavouros_Cassini_Nova-03-2023_R3.iso

I was able to install ubuntu, mint, solus, etc., with this same pc/configuration.

Any ideas? Thanks.

I do almost all my testing in vmware. There shouldn’t be any issues there.

How much RAM did you allocate that VM?

Thanks. I allocated 4GB. This is the error:

That looks like a problem with the ISO itself to me.

Are you reading the ISO from a file? If so, I suspect there is an issue with that file or the underlying storage.

I am pointing vmware to an iso, just like I did with all the distros that I tested.

In fact, I just finished installing Fedora with the same steps. 0 problems.

I downloaded the ISO twice, and the second time I checked it with SHA512 and it matches.

Where did you download it from?

From one of the mirrors listed on the main website.

I am currently re-downloading this one:

But as I said, the SHA512 matches.

EDIT: finished downloading the github ISO, both matches.

What option do you choose here?

2023-08-30 22_16_20-New Virtual Machine Wizard

The one from your screenshot is what I usually choose.

I just downloaded the ISO you linked and loaded it in Vmware 17.0.2 without issue.

OK, I fixed it by selecting the Debian 11.x 64 bit option.

Then it worked.

It appears I spoke too soon. It has been stuck at 37% for more than 15 mins.

Click that toggle log button and see what is going on.

Sorry, where? The guest is completely dead. This time at the same 37%, but installing ruberband.


Thanks. It freezes it always at 37%, but at different times. I tried installing from the ISO on my SSD or my HDD. The result is the same.

here is another run, still at 37%, but now installing some mate applets

Is the only distro that is having issues. Very weird.

Can we see all the settings for that VM?

OK, it worked. The problem is that the RAM assigned was 2GB, I assigned 4GB, and it worked!

Thanks for your support :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.