Try to use Obs-Studio with Virtual Cam

I have the same problem than @Chewing_Bever :slight_smile:

I wanted to use the OBS virtual cam feature to stream some games to my friends via Discord, but it’s refusing to output a signal. I’ve installed the v4l2loopback-dkms package, which enabled the option in OBS. When I click Start Virtual Camera, a popup shows up asking for root privileges for running modprobe, and afterwarts, a new camera output is created named OBS Virtual Camera. Sadly, this device doesn’t actually output anything. I’ve used both Discord and Zoom for testing, an both confirm that no output is coming through the loopback device. I’ve tried both a scene with just my webcam and one with screen share + webcam, neither work.

Reproduce the probleme :

  • install obs-studio 27.1.3 and v4l2loopback-dkms
  • try to use the virtual cam with jitsi :

I’ve tried many Obs-studio version in AUR, without output. No Obs Cam is output.

Virtual Cam in Obs studio only work with a flatpak install.

Is there a workaround to make it work, with arch install ?
Best regards

what DE/WM do you use? as there are issues with OBS under XFCE4 and i do have issues on i3 also.
And Nvidia Drivers can be troublesome also.

So, problem may be, in my case, XFCE or Nvidia.

#################### inxi -Fxxc0z ########################

System:    Kernel: 5.15.2-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0
           tk: Gtk 3.24.29 wm: xfwm dm: LightDM Distro: EndeavourOS base: Arch Linux
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x serial: <filter>
           UEFI: American Megatrends v: 5861 date: 08/10/2021
CPU:       Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ rev: 2 cache:
           L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86424
           Speed: 3062 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3062
           2: 2206 3: 4265 4: 2125 5: 2158 6: 2135 7: 4251 8: 2122 9: 2741 10: 2118 11: 2176
           12: 2120
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 495.44 bus-ID: 08:00.0
           chip-ID: 10de:1c03
           Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 5-2:3
           chip-ID: 046d:0825
           Display: x11 server: compositor: xfwm4 driver: loaded: nvidia
           resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel
           bus-ID: 08:00.1 chip-ID: 10de:10f1
           Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 0a:00.3 chip-ID: 1022:1457
           Device-3: Corsair VOID PRO Wireless Gaming Headset type: USB
           driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-14:2 chip-ID: 1b1c:0a14
           Device-4: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 5-2:3
           chip-ID: 046d:0825
           Sound Server-1: ALSA v: k5.15.2-arch1-1 running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: yes
           Sound Server-5: PipeWire v: 0.3.40 running: no
Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel port: e000
           bus-ID: 06:00.0 chip-ID: 8086:1539
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb
           v: 0.8 bus-ID: 3-1:2 chip-ID: 0a12:0001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.27 TiB used: 80.58 GiB (3.5%)
           ID-1: /dev/sda vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB speed: 6.0 Gb/s
           serial: <filter>
           ID-2: /dev/sdb vendor: Western Digital model: WD2500JD-00GBB0 size: 232.89 GiB
           speed: 1.5 Gb/s serial: <filter>
           ID-3: /dev/sdc vendor: Crucial model: CT250MX500SSD4 size: 232.89 GiB speed: 6.0 Gb/s
           serial: <filter>
Partition: ID-1: / size: 29.3 GiB used: 22.91 GiB (78.2%) fs: btrfs dev: /dev/sdc5
           ID-2: /boot/efi size: 96 MiB used: 29.8 MiB (31.1%) fs: vfat dev: /dev/sdc1
           ID-3: /home size: 71.45 GiB used: 57.64 GiB (80.7%) fs: ext4 dev: /dev/sdc6
           ID-4: /var/log size: 29.3 GiB used: 22.91 GiB (78.2%) fs: btrfs dev: /dev/sdc5
Swap:      ID-1: swap-1 type: partition size: 7.96 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/sdc7
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 340 Uptime: 3m Memory: 15.59 GiB used: 1.47 GiB (9.4%) Init: systemd v: 249
           Compilers: gcc: 11.1.0 Packages: 1218 pacman: 1213 flatpak: 5 Client: shell wrapper
           v: 5.1.8-release inxi: 3.3.07

So, I must use a flatpack install, if I understand correctly.