Troubles with screenshots


I’m using integrated with CPU graphic - i5-1035G1. I have two FHD displays.
When i’m trying to make a partial screenshot(like drawing a square on something) using Spectacle, Shutter or Flameshot one of my displays are going empty black, second one is starting showing only wallpaper.
Look’s like every attempt to make a screenshot is minimalizing everything on main display and secondary one make black.

What’s more funny for me - if i will make screen of entire screen (both displays) sometimes it’s displaying random apps on them. For example - i had minimalized Element, on screenshot it appear with conversation from 5 mins ago. Even if there are some newest messages. Like time goes back for that app on screenshot.

I just switched from Ubuntu 20.10 with KDE also and i don’t had that problem there.

Does anyone have a idea how i can fix that? It’s really annoying.

Hey, I had the same problem. Removing xf86-video-intel seems to have fixed it. Given that you’re on 10th, you probably don’t need that package either.
(Ideally, endeavourOS shouldn’t even install it unless it’s needed for older systems).

I had the same problem, and removing xf86-video-intel seems to have solved that, but some widgets and menus look uglier (I have 175% scaling). I then reinstall that and set the Compositor rendering backend to OpenGL 3.1; this seems to have solved the problem as well, at least for the moment.

Actually, also with opengl 3.1 the problem is experienced now and then