Trouble with my Elan Touchpad and also hello guys

This is my first post in this forum. first of all thanks for being open to newbs and other distro users. also for some odd reason this forum wouldn’t open in India Without a VPN.

Coming to the issue my touchpad is unresponsive random clicks and moves like its gets stuck frequently.
No Idea where to start with this issue I’ll just post my machine name and xinput list ouput.

Model: Hp pavillion gaming 15-ec0066ax (amd 3550h, vega 8 & gtx1650)

|⎡ Virtual core pointer                    |id=2|[master pointer  (3)]|
|⎜   ↳ Virtual core XTEST pointer              |id=4|[slave  pointer  (2)]|
|⎜   ↳ Corsair Corsair Gaming HARPOON RGB Mouse|id=10|[slave  pointer  (2)]|
|⎜   ↳ ELAN0718:01 04F3:30FD Touchpad          |id=13|[slave  pointer  (2)]|
|⎜   ↳ ETPS/2 Elantech Touchpad                |id=15|[slave  pointer  (2)]|
|⎜   ↳ ELAN0718:01 04F3:30FD Mouse             |id=12|[slave  pointer  (2)]|

For some odd reason there is 3 pointer for my single trackpad? and the other one is my mouse

Welcome to the forum. Thanks for giving EndeavourOS a try. I hope you enjoy your time here.

Unfortunately I know nothing about Touchpads, but I am sure someone will come along to help you out.




1 Like

Might work, do not forget to update grub:

sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

Hello xircon, thanks for taking the time to try and help me.
found this while doing some basic forum searching and tried this prior, didn’t help me. also for the record i tried multiple distros and also this other fix didnt help

Did you try any of the kernel parameters in the default grub command line. I would start here and try these two first.

i8042.reset i8042.nopnp
1 Like

Sorry my english is poor, I tried the above mentioned kernel parametrs didn’t change a thing.
This other dude pretty much has my same machine and i couldn’t understand much of what he and the others were saying

Did you do the kernel parameters properly and then run sudo grub-mkconfig -o /boot/grub/grub.cfg
and reboot.


Yes I did could see the osprober run and everything. Its almost a habit now after the windows driver reboot days.

Doesn’t look like an issue with the forum. I will suspect your ISP. Yesterday, I also couldn’t access the forum and main website. Used a different network to access it.

Today its back to normal for me.

I moved your post to General system/Kernel & Hardware category.

1 Like

Now it seems to work AOK. Jio fiber perks i guess. I guess thanks for moving catagories.


For some odd reason now my xinput list changed and the trackpad wouln’t even work. I undid every change the forum mentioned before and now I get

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Corsair Corsair Gaming HARPOON RGB Mouse	id=10	[slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                      	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Lid Switch                              	id=9	[slave  keyboard (3)]
    ↳ HP TrueVision HD Camera: HP Tru         	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
    ↳ HP WMI hotkeys                          	id=14	[slave  keyboard (3)]
    ↳ HP Wireless hotkeys                     	id=15	[slave  keyboard (3)]

hey, did your issue get solved? I’m having the same problem in same pavilion gaming . please help me if your touch pad started working now

I did figure it out… It’s mostly that hp writes bad bios. This reddit article helped

Look for the comment by shark biscuit.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.