Trouble with installing MegaSync

I am having trouble installing MegaSync. I have downloaded the files (megasync-x86_64.pkg.tar.xz and dolphin-megasync-x86_64.pkg.tar.xz) and installed using the command:
sudo pacman -U filename

Both packages installed without any errors. When I went to the menu and clicked on the launcher, I get no response. In looking at the file directory, there is not a MegaSync directory.

I am running the KDE Plasma desktop and it appears MegaSync is installing just fine – but… it’s not working.

Does anyone have any suggestions? Thanks in advance for your help.

I am not sure I can be any help - but I do have a question… with 15 different packages in the AUR, why download the packages, and from where? Just from a quick look (using yay) I would expect that megasync and dolphin-megasync would be fine from there…?

(and would install in a more usual manner)

Maybe try the git version.

yay -S megasync-git

I downloaded the packages from Mega. Not being familiar with this operating system, I didn’t catch the yay tool and the AUR repository. I knew the AUR existed, I just thought the delivered app Discover would have it included. A typical newbie mistake I guess.

Looks like I have more of a learning curve ahead of me. But that’s just the fun of it all.
Thanks so much for the help!

1 Like

Thanks so much for the suggestion! Helps to have more than one route to try.

It appears from your suggestion and from Freebird’s suggestion that I better start getting up to speed on yay. The Discover app isn’t going to cover everything.

Thanks for helping out a newbie!

Freebird54 and ricklinux,

Well, that was fun and a great learning experience! Here’s what I went through (bottom line - it’s all working great.)

I took ricklinux suggestion first and simply ran the command. That was a mistake. File conflicts everywhere. So that was a stupid move on my part. I should have known better.

So I ran “sudo pacman -Rs megasync” to clear things out.

Then I ran “yay megasync” to get the package selections again.

I selected 1 and 5 (megasync and the dolphin package) and went from there with no conflicts.

After lots of colors flying by, everything installed and it’s running great.

Thanks once again to the both of you for providing help! Now I’m just a little bit more knowledgeable. So if I could just convince my wife I’m more knowledgeable, I’ll have it made.

1 Like

No problem - we’re here to help. I have a suggestion for the future though… it might have gone even faster if we had known how new you were to Arch-based systems! I suspect we could have directed your research more effectively! Glad you got it - and I’m sure the wife will figure it out after a while :grin:

I’m glad it worked out for you and you learned something along the way. Knowing what desktop you are using does help. I didn’t actually see the Dolphin package but to be honest i wasn’t really looking for that. I took a look and saw some of the megasync packages and thought maybe the git version might work. I’m happy you figured out yay. I use it a lot along with pacman because it does the AUR packages as well. Pacman is the defacto package manager but if it’s an AUR package then yay is what you will most likely use. Not always…but probably most of the time. Welcome to EndeavourOS!