Trouble loading the NVIDIA driver

this is the result for: nvidia-settings and FYI the driver is installed using nvidia-inst the noveau driver installed fine as inxi -Ga showed but I am having problems with the non-free driver.


ERROR: NVIDIA driver is not loaded

(nvidia-settings:3368): GLib-GObject-CRITICAL **: 22:14:53.984: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** (nvidia-settings:3368): CRITICAL **: 22:14:53.994: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed

ERROR: nvidia-settings could not find the registry key file or the X server is
       not accessible. This file should have been installed along with this
       driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Are you using the nouveau driver instead of Nvidia driver?
Please show the output of

inxi -CGza
1 Like

I was also having the same trouble before with the non-free driver so I just settled with nouveau because it was the only working properly but it just doesn’t have the performance I need.

output for inxi -CGza

  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1050 high: 2800 min/max: 800/3800 scaling:
    driver: intel_pstate governor: performance cores: 1: 800 2: 800 3: 800
    4: 800 5: 2800 6: 800 7: 800 8: 800 bogomips: 44817
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:591b
    class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell driver: N/A
    alternate: nouveau non-free: 530.xx+ status: current (as of 2023-03)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-12:5 chip-ID: 0c45:6713 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: gnome-shell v: 43.4 driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: Sharp 0x1476 built: 2016 res: 3840x2160 dpi: 282
    gamma: 1.2 size: 346x194mm (13.62x7.64") diag: 397mm (15.6") ratio: 16:9
    modes: 3840x2160
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 630 (KBL
    GT2) direct-render: Yes

You are using Intel gpu and Nvidia card has no driver there.

Do I understand correctly that you wish to use the Nvidia driver instead of nouveau?

Please show the output of this:

pacman -Qs xf86-video
pacman -Qs nvidia
1 Like

Yes, you are right I do want to use the NVIDIA driver instead of Nouveau.

This is the output for: pacman -Qs xf86-video. This command produced no output.

This is the output for pacman -Qs nvidia

local/egl-wayland 2:1.1.11-4
    EGLStream-based Wayland external platform
local/envycontrol 3.2.0-2
    CLI tool for Nvidia Optimus graphics mode switching on Linux
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 530.41.03-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 530.41.03-1
    NVIDIA drivers - module sources
local/nvidia-hook 1.3-1
    pacman hook for nvidia
local/nvidia-inst 23-5
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-installer-common 23-6
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-settings 530.41.03-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 530.41.03-1
    NVIDIA drivers utilities

Are you using kernel parameter
If so, it should be visible in the config file of the bootloader. For example in grub it is /boot/grub/grub.cfg and in systemd-boot it is /etc/kernel/cmdline.

1 Like

I went through this article and added the nvidia-drm.modeset=1 line to it.

So… did it help anything?

Nope. nothing I have never experienced this before when I tried to switch from Nouveau to NVIDIA I did nvidia-inst and it removed Nouveau and then installed it and after restarting and no changes.

Please show this log when you try to use the Nvidia driver:

cat /var/log/Xorg.0.log | eos-sendlog

Do you mean I should switch from HYBRID to NVIDIA then run this command?

After switching to Nvidia

  1. reboot
  2. try to go to TTY and run the command
1 Like

Went to TTY and it says “No such file or directory”

Can you show all details, like the command and the output, or a screenshot?

It says /var/log/xorg is the directory correct? I am on Wayland would that make a difference?

Yes it would.
Then you could show (in TTY) the URL returned by

sudo journalctl -b -0 > /tmp/foobar
# you can check that file /tmp/foobar does not contain
# anything you want to keep secret, e.g.
# less /tmp/foobar
cat /tmp/foobar | eos-sendlog
1 Like

Here you go:

Have you tried using X instead of wayland?

You are using gnome which unfortunately is not my cup of tea. Hopefully gnome experts here can analyze the log.

Please try X11. I had similar problems in other distros. Wayland doesn’t like NVIDIA at all. You can’t see NVIDIA settings and stuff.