Trouble installing NVIDIA

inxi -Ga

Device-1: NVIDIA GK208B [GeForce GT 730] driver: nouveau v: kernel non-free:
series: 470.xx+ status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
process: TSMC 28nm built: 2012-18 pcie: gen: 2 speed: 5 GT/s lanes: 8
ports: active: HDMI-A-1 empty: DVI-D-1,VGA-1 bus-ID: 25:00.0
chip-ID: 10de:1287 class-ID: 0300 temp: 30.0 C
Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev,nouveau,nv,vesa dri: nouveau
gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Samsung LF24T35
serial: H1AK500000 built: 2020 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 528x297mm (20.79x11.69") diag: 606mm (23.9") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.3 Mesa 22.3.4 renderer: NV106 direct-render: Yes

I have successfully used this guide many times in the past ( distro hopper here ) -

nvidia-inst --legacyrepo

2023-02-18 16:43:06: Error: sorry, currently nvidia-inst does not support any 3rd party repo for legacy drivers.

nvidia-inst --drivers

NVIDIA card id: 1287
Fetching driver data from …

Series 470: supported ( 470.161.03)

nvidia-inst --series 470 -t

2023-02-18 16:44:15: Info: Running: nvidia-inst v1.13-1
2023-02-18 16:44:15: Info: Command line: nvidia-inst --series 470 -t
2023-02-18 16:44:15: Info: Selected mode: nvidia
2023-02-18 16:44:15: Info: Installing packages: nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings

    pacman -Syuq --noconfirm --noprogressbar --needed nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings
    nvidia-installer-kernel-para nvidia-drm.modeset=1 add

2023-02-18 16:44:15: Error: sorry, currently nvidia-inst does not support installing Nvidia series 390 and 470 drivers.

I don’t know what to do.

Same situation here : 470-xx can only be installed with LTS kernel.

the legacy repo is gone with @jonathon (RIP)

The 470xx AUR builds now have a new maintainer but the repo is not there anymore and the 390xx AUR builds are still unmaintained.

And I do not see Menelkir updated nvidia-470xx-dkms so also them are still not up to date.

So @fakemishraji you need to use yay to build from AUR at least… but as @sissou could be they still not working with latest kernel not sure about dkms version what could work with latest…

yay -Syu --needed nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings


Perhaps it would be appropriate to update that wiki article and remove info regarding legacy repo (in addition to disabling/removing such option inside nvidia-inst itself).

At current state It can be confusing to new users.


This worked like a charm! Absolutely indebted to you for the prompt help.

1 Like

Updated the wiki article about nvidia-inst.
Thanks for the heads-up! :smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.