Triple monitor setup

id like to see if there is a solution to my tricky problem
i currently have a dual monitor setup, one is connected via dvi and another via hdmi.
i wanted to try and connect a third monitor via vga
however it seems to not recognize it, i was unable to find it in display, nvidia settings and tried xandr as well

any help would be appreciated

well, i have further conundrum with this specific problem.

i thought i could buy a DP cable to connect to the third monitor, hoping it would be recognized instead of the vga cable, sadly it is not.

the thing is i recall in manjaro that a 3 monitor setup was possible after deleting a specific file in “/etc/X11/xorg.conf.d”, which i tried to find, but this file is not present.

i wish i could give any more specific information but sadly i dont know what to give.

What graphics driver are you using?

lsmod | grep -P 'nouveau|nvidia|ati|radeon|amd|i915'
1 Like

nvidia 460.67

1 Like

Can you try nvidia-settings?

1 Like

i tried nvidia-settings in my quest but it it doesnt seem to recognize it, using the “detect display” button didnt work either

And what did xrandr show?

Screen 0: minimum 8 x 8, current 4480 x 1440, maximum 32767 x 32767
DVI-D-0 connected primary 2560x1440+1920+0 (normal left inverted right x axis y axis) 698mm x 393mm
2560x1440 59.95 + 74.78*
1920x1200 59.88
1920x1080 60.00 59.94 50.00 60.00 50.04
1680x1050 59.95
1440x900 59.89
1280x1024 75.02 70.00 60.02
1280x720 60.00 59.94 50.00
1152x864 75.00
1024x768 75.03 70.07 60.00
800x600 75.00 72.19 60.32
720x576 50.00
720x480 59.94
640x480 75.00 72.81 59.94 59.93
HDMI-0 connected 1920x1080+0+193 (normal left inverted right x axis y axis) 698mm x 392mm
1920x1080 60.00*+ 60.00 59.94 50.00 60.05 60.00 50.04
1680x1050 59.95
1600x900 60.00
1440x900 59.89
1440x576 50.00
1400x1050 59.98
1280x1024 60.02
1280x800 59.81
1280x720 60.00 59.96 50.00
1024x768 60.00
800x600 60.32 56.25
720x576 50.00
720x480 59.94
640x480 59.94
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

this is pretty much what i got with the vga cable as well

I’d try unplugging one of your two working monitors and then trying to get the plugged vga monitor show at least something useful with xrandr.

By the way, what kind of machine are you using? Arch wiki might have some related info. For example: https://wiki.archlinux.org/index.php/Xorg#Multiple_monitors and
https://wiki.archlinux.org/index.php/NVIDIA#Multiple_monitors

2 Likes

oh wow, im not sure how and why playing around with plugs was the resolution but, two monitors started working (hdmi and DP)
and after plugging in the third all worked now.

thank you for your help!

1 Like

Great that you got it working!

It must be the magic of the following essential remedy operations:

  • unplug and plug
  • reboot

:thinking: :sweat_smile:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.