Tried to plug monitor back into mobo to use integrated graphics, but can't log in normally anymore

GPU: 3060TI
CPU: i5-10400

Hi all. I have a relatively modern computer and I use my GPU for solely computational work. But with my monitor plugged into it, it would cause system lag.

So I decided to switch to having it plugged into my mobo.

I switched my BIOS settings so it would default to integrated graphics, and it at least detects my monitor now.

But when I reboot, it doesn’t show the login screen.

I can still control + alt F2 to get to the terminal. And I ran journalctl but don’t see any errors.

Does anyone have any ideas? I could not find anything online. I might not be searching for the right thing.

I just wanna allow my GPU to do its own thing while I use my computer’s integrated graphics for web browsing or other light work :slightly_smiling_face:

I’m no expert, but posting the result of inxi -G, preceded and followed by triple ` will go a long way for figuring it out.

What video driver is active? Might be as simple as that…?

1 Like

I did this, it looks like it’s detecting it correctly? Confusing for me. sorry

It shows both drivers loaded. Do you have optimus manager set up to switch graphics?

Edit: Actually I’ll rephrase that. It looks like the Intel is running on modestting kernel driver maybe? Did you try rebooting?

Edit2: Is the Intel driver installed?

pacman -Qi xf86-video-intel

1 Like

I switched back to my normal GPU setup so I could talk here a bit easier. Here is a screenshot. It looks like the Intel graphics driver is installed. I have rebooted a number of times.

I do not have Optimus manager set up. I looked at the page, and it seems like it’s for laptops?

Sorry, You are right i was thinking it was a laptop.

1 Like

I’m not sure what would have happened. I assume you shut it down when you changed the cable over to the motherboard?

1 Like

I’m not sure either. I even got a little impatient and reinstalled EndeavourOS (wiped my drive) because it’s not too hard to set up what I use. This time, I kept my monitors plugged into my mobo.

The installation went fine. But after it finished, and I installed Nvidia and rebooted again, the same issue came back up.

So it seems as though if I have Nvidia installed while my monitors are plugged into my mobo, this keeps on happening at the moment.

So you have more than one monitor?

Edit: Could you install mesa-demos

sudo pacman -S mesa-demos

Then run

inxi -Ga
1 Like

Yes, but I also tried to start my computer with only the one monitor plugged in. Although, I’m not sure if that’s what you meant :slightly_smiling_face:

edit: I just saw your edit. I installed mesa-demos. I’m not sure if you want me to run that inxi command now, but here it is if so. This is with my current normal setup, with both monitors plugged into my GPU. I will shutdown and reconnect to mobo if you need.

1 Like

Looks correct. So let me ask so i understand fully. When you boot on the Intel it’s working?

Edit:
Does it show on both monitors or just the one hooked to the motherboard?

1 Like

Sorry, I’m not sure I understand the question, sorry for my ignorance. Do you mean if I boot on the integrated graphics? I don’t know how to be sure that I am.

All I know how to do is plug into either the GPU or the mobo haha.

But when both monitors are plugged into either the GPU or the mobo, they both are recognized (provided that I enable that setting in my BIOS - if I don’t do that, then I get blank screens when plugging into mobo).

Not sure if needed but this is my mobo: https://www.msi.com/Motherboard/Z490-A-PRO

Give me a minute to look at the manual. Can i ask one question though. Do you have the monitor plugged into HDMI on the motherboard? How is the dedicated graphics card plugged in to the other monitor?

1 Like

Both my mobo and my GPU have slots for both of my monitors. I haven’t tried to mix between them. At this moment, both monitors are plugged into my GPU :slightly_smiling_face:

Sorry, I know this is probably confusing haha.

edit: I missed a specific thing you asked. My older monitor is HDMI, my high end monitor is a display port hookup.

If you have both monitors plugged into the dedicated GPU it is only running on the NVIDIA card. In order to use the Intel Integrated Graphics the monitor has to be plugged into the HDMI port on the motherboard and set in UEFI Bios to use Integrated graphics. The integrated onboard Graphics is on the processor. That is the only way the integrated graphics work through the HDMI port or the Display port on the motherboard.

1 Like

We are on the same page. I only plugged into my GPU at the moment because it’s easier to talk to you here, otherwise I’m reduced to responding to you on my phone.

I can restart and switch that in the BIOS + plug back into my mobo at any point, but then I am limited to the command line since I cannot log in normally.

I’m not quite following what the problem is.

Edit: Currently you are plugged into what?

1 Like

With my monitor(s) plugged into the mobo, I cannot log in normally, I don’t see the welcome screen. I have to control+alt F2 to even get to the command line. I cannot log into XFCE for example.

At this moment I am plugged into the GPU while we are talking.

So dedicated graphics card? Nvidia?

1 Like

Yes, sorry. I am plugged into my Nvidia card at this moment.