Tried to install brave browser and ended to a mess

Totally my fault what happened but I want to understand what exactly happened :slight_smile:

Today I had to install few programs from repository and I did that without issues, then I needed another browser beside firefox and I wanted to install brave, so I wrote in console: “yay -S brave” (I updated OS few hours prior to this). At the same time I was doing something else and I just hit enter every time I was asked something in console and inserted sudo password when asked for it. Yes I know, I shouldn’t do that… Anyway, I was doing something else at that time and I noticed after 20min that browsers still isn’t installed. I didn’t wanted to interrupt because I didn’t want to mess something up… Because I was working on some project I didn’t care if it takes a few minutes more to install, but after 3 hours, it still wasn’t finished, and a few times the computer became unresponsive for a minute or two.

I have a cpu usage widget where I noticed that often my cpu went to 100%. I noticed in console that script downloaded more than 50gb of data and still didn’t finished. Anyway, after around 3,5-4 hours all my cpu cores went to 100% and everything froze for around 5 minutes … then console crashed and system start to work again as nothing happened. I checked space usage of my home folder and under ~/.cache/yay I had over 100gb of data.

I used yay -Scc to clear that cache and rebooted my computer. All works fine and brave browser is nowhere to be found, so my question is what the hell happened?

I remember once that I clicked to rebuild a package or something similar and it took around 20min but this thing worked for almost 4 hours and then crashed.

Thanx for any info.

I have a feeling you were trying to compile the browser from source and your computer gave up. Pretty common. Try brave-bin instead, it should get you better results. There is also a Brave Flatpak if you want to go that route.

1 Like

I agree with you.
Doing it from source code can take ages.

Just yay -S brave-bin
I just installed it a few days ago and it was fast.

So… compiling a browser from source is too demanding for my pc :slight_smile:

However, how a noob can know that “brave-bin” is better choice than “brave” ?

By hitting it and facing problems, then asking questions.
I guess now you learned that xyz-bin is faster to install than xyz!
One of the beauties of Linux is you are learning all the time!

Using the binaries means it’s already been compiled by someone else. It’s not too often that you need to go that route, it’s really just that browsers are a lot more complex than you would think.

1 Like

Also the brave-bin PKGBUILD clearly shows that it’s retrieving binaries from brave’s CICD actions on github, and not a user’s build. Which is nice.

1 Like

Thanx all for explanations, I will be more careful in the future when I will try to install something.

A fully featured browser is a monumentally large piece of software. Compiling it from source is a very difficult task. Even on a very fast machine it will likely take 30-40 minutes.

It is OK to build things from source but you might want to stay away from browsers.

You should know what the AUR suffixes represent:

  • A -bin suffix means that a prebuilt binary is being downloaded and installed. In theory, the binary should be coming from an official source but you should always check that.
  • A -git suffix means the package is being built from source code on your machine, typically the absolute latest source which is unreleased and often untested.
  • No suffix is a bit more complicated
    • If the package is open source, it should be downloading and building the released source on your machine
    • If the package is closed source, it will be downloading a prebuilt binary

Of course, not all packages are named correctly but the above rules will hold true 90% of the time.


Learnt about this some days ago. Usually, if there’s a “bin”, use that, at least for browsers.
Compiling from source anything could take ages. And if you’re in doubt of the security of the package, use flatpak instead.

1 Like

I always use yay -S brave-bin for Brave browser. As the previous speakers have already written, compiling from source can take years :wink:

The exact same thing happened to me a few days ago. In my case I wanted to install Librewolf and I used yay -S librewolf. So I waited 10 minutes and the program kept “downloading” but it was actually compiling.

So I asked here on the forum and our friends explained to me what was happening. Luckily I didn’t wait for it to finish, since I read on reddit that it can take 8-10 hours, but on old PCs like mine, it could take days.

So, as our friends have already told you, it’s because there are some programs that start compiling when you download them, like browsers (I don’t know if it’s just browsers, because steam, blender, gimp, etc, took a few seconds to install) , and you should download the compiled -bin version, which is already compiled and ready to use.

Good luck friend!

Steam, for example, is closed source meaning when you install it you will be downloading a binary anyways. At most you will be automatically patching it.

Even a lot of other applications including open-source ones that do not have any suffixes still download binaries, specially ones that are in the official arch repos.

Everything in the repos should download a binary unless the target isn’t something that is compiled such as a script or data file.

Those naming conventions are only used for the AUR.

Good info to know :slight_smile:
So, I can install anything I like from official arch repo without problems but I need to be a little careful when installing something from AUR

1 Like