Transparency missing in Plasma

Shortly after I posted my desktop here I noticed that I no longer have any transparency in Konsole, the panel, apps menu, or KSmoothDock. Anyone have any idea what might be causing this? Thanks

EDIT:

Forgot to mention that the desktop effects aren’t working as well, and they were before I lost transparency,

Hi! You must have changed some setting or updated something in this time?

Regarding your edit, it sounds like your compositor is switched off somehow.

This was my guess as well, but I assumed so cause of having a black background for KSmoothDock when it should be transparent. Never figured that the effects would be tied to the compositor.

Most effects are governed by a compositor as far as I know. I used to run Manjaro with just Fluxbox as the window manager without a desktop environment, and without adding a compositor everything was opaque and pretty much static! :grin:

Yea I know that now, LOL. Did one more Google search and found a post on Reddit that led me to the solution in system settings. Had to reenable compositing and reboot. Works perfectly again. Pretty sure it was Handbreak that disabled it. Think I ended up with a GTK2 version instead of a GTK3 version.

Just to check next time: alt+shift+f12 will toggle compositing, no reboot necessary.

6 Likes

Are you kidding me. leave it to google NOT to come up with a search result that includes that. Thank for the info.