Transferring data from one EOS system to another EOS system

Hi everyone,

for quite some time, I have been looking for a way to transfer my files and folders from one laptop (ASUS Vivobook M3500Q) to another laptop (ASUS Zenbook 14) in the same network. Both laptops are running EOS with Plasma Desktop.

First I tried to configure samba, but I never got it to work no matter what I tried in configuration and no matter what I tried to do based on online resources including our forum.
I also tried to share my files with other graphical and terminal applications, such as rsync, KDE Connect, Filezilla, and Warpinator, but none is working.

Trying to ping the IP address of the other machine does not work either. I do not know much about networking, but because of this, it seems to me that the problem might be with the network in some way (but both machines are connected to the same network), or with the firewall (both machines use firewalld that comes pre-installed with EOS).

Where to start troubleshooting? As mentioned above, my goal is to transfer files and folders from one machine to another in a way as quick and simple as possible, be it GUI or CLI.

I put this topic into the category Desktop Environments > Plasma, but it can be moved if it fits better somewherer else.

You need to open the ports in the firewall.

Trying to use Warpinator, the ports are supposed to be 42000 for transfers and 42001 for registration. Here’s a screenshot (sorry, it’s in German. If something needs to be translated, I can translate it if needed)

So I try to open both ports in firewalld on both my machines, like this

i.e. clicking on home, the tab ports, typing the port number and leaving the protocol tcp as preset. Am I doing anything wrong there / opening the wrong port ?

Warpinator fails to connect.
In Filezilla, it fails to connect with the message “EHOSTUNREACH - Keine Route zum Host” (EHOSTUNREACH - No route to host) on both sides
I am able to ping the machines though.

You need to use to switch to the “home” zone. You are using the public zone right now.

Also, you don’t need to manually open ports like that. You can check the box next to “warpinator” in the services list.

“Switch to home zone”: The button “Switch zone” at the bottom left is greyed out. Can I switch to home zone via Options > Switch standard zone (or is it Change standard zone? Sorry, the German word can mean both)

If I want to open the port for Filezilla, what do I need to do? I can not find “filezilla” in the services list.

You change your zone in the network settings, not the firewall. NetworkManager manages that.

Filezilla transfers files a bunch a different ways. You probably want “ftp” or “ssh”

Switching to home zone: In Plasma System Settings > Network > Connections > General Settings, I have selected Firewall-Zone: home as in this screenshot.
Sorry for my dumb questions: Is this the right way to do it? When I reopen firewalld, “public” is still the entry which is bold, not “home”.

Yes. Then hit apply.

Look at the connections list on the left, what does the zone show there?

@dalto Look at the connections list on the left, what does the zone show there?

Yes, it shows “Zone: home” underneath the name of my network.

Now I have made sure that “warpinator”, “ftp” and “ssh” are checked in firewalld on both machines.

Filezilla still shows the same error as before. Warpinator still says it can not find any other machine, and when I try to copy a file via the terminal: cp text.txt m..@m..-laptop:~/Downloads, it cannot do that either.

If the main goal is just transferring files, why not stop the firewall temporarily, and copy your stuff via sftp? (i think that is the easiest path to take).

What would I do:

  1. Stop the firewall on Zenbook (or both laptops) with sudo systemctl stop firewalld
  2. Make sure ssh is enabled on ZenBook sudo systemctl enable --now sshd
  3. On Vivobook, open Dolphin file manager, focus the address bar (Ctrl + L) and enter sftp://ip_address_of_zenbook
  4. After a successful login, open a new window in Dolphin, navigate to the files you want to copy and just drag-and-drop them to zenbook window

Thank you very much, this sounds like the quick and simple solution I am looking for.

Now the two machines connect. I am able to use Warpinator now to transfer files (but not Filezilla). So file transfer is possible, but

I am trying this, and it just loads and never finishes loading.
Also entering sftp://{username[:password]}@{domain}/{path} or fish: instead of sftp: in Dolphin’s address bar, as suggested here, just makes Dolphin load forever.

If there’s any easy way to find out how to solve this, I’d be thankful.
Otherwise, I tag this as solved, because now file (and folder) transfer is possible with Warpinator.
Thank you @jake99 for the easy path, and thank @dalto for your patience with my questions.

NFS, SSH, rsync, etc. Lots of tools.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.