Transfer Windows sensitivity to EnOS

I read Mouse acceleration - ArchWiki (archlinux.org), but I must say that I didn’t really understand it very well.

My goal is to get identical (if possible) mouse sensitivity on Linux as I have it on Windows.

These are my current Windows mouse settings that I wish to transfer over to EnOS.


I know that people don’t like Mouse Acceleration, but it is a must for me when browsing the desktop.

In Linux(EnOS) the sensitivity just feels off, and I don’t know what’s the issue. If it may not be possible to get identical sensitivity, I would at least like to get close it.

I use Logitech G Pro Wireless mouse. Via its software on Windows I have set the DPI to my desire (700) and Polling Rate to 1000. I saved those settings on the On-Board memory of the mouse, so on EnOS the settings should transfer over regardless of me having the Logitech Software installed or not.

When I go into the “about” section of Settings on EnOS it says that I am using Wayland.
I also run EnOS with GNOME.

Any help is much appreciated.

you can change the mouse settings in the gnome GUI. settings >> mouse & touchpad

Edit:
with gnome-tweaks you have more options to control. you may have to install it first.

I was in there (settings → mouse & touchpad), but there is just a slider like on your picture. I did set it up at half speed (just like your picture, and just like it is in Windows right now), but it wasn’t the same sadly :frowning:
I do have gnome-tweaks already installed(I think they come preinstalled with EnOS), but I haven’t found anything regarding mouse in there.

have you tried it with piper?

https://archlinux.org/packages/community/any/piper/

I have tried it out. Unfortunately I was only able to set DPI and Polling Rate via Piper. I tried setting same DPI and Polling Rate as on Windows, but the sensitivity felt like at least twice as fast as on Windows, with weird feeling regarding acceleration.

sorry can’t help you further. surely someone else will be able to help you with this.

1 Like

I remember that I had issues when I had my mouse working at a higher DPI than the default setting. I always had switch back and forth the DPI/profile when I attached it to the company laptop with windows on it. But it still felt very odd on linux (somehow the mouse acceleration profile was really bad compared to windows, even when trying to tweak mouse speed settings)

I could finally fix it by specifying the additional DPI settings in udev hwdb:

If you want to play around with that here are some instructions:

2 Likes

Thanks for that suggestion, but that is too confusing for me. I don’t understand the instructions exactly, and am afraid of messing something up.

I really hope that something easier exists.

Since you found the solution in the meantime, as posted in another thread, you could simply mark it as solved with a link to your found solution in this thread.

:v:

Solution (not exact solution):

Don’t know exactly how to do that.
I did somehting right now in a comment under, but am unsure if I did it correctly. Is that what you meant?

1 Like

Yes, exactly.

:v:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.