Touchpad too sensitive and no option to adjust it

Hi everyone,

I installed EndeavourOS (offline install with XFCE, dual boot with Win7) on my 10-year-old Dell laptop 10 days ago, and so far I am very happy with it. And although I am still a half-beginner in using Linux (have used Ubuntu for half a year now), I am getting along with it very well, except for a few small things.

One issue is that my touchpad is much too sensitive, so my mouse pointer wobbles and jumps away when I try using it and clicking icons with it. It’s working perfectly well under Windows 7.
In the XFCE mouse settings there is no slider for sensitivity, even though there is one in the first picture in the XFCE help. I have searched online, found different results and tried lots of them:

  • I tried to use xinput in the terminal: *xinput --list-props “AlpsPS/2 ALPS GlidePoint”
    *. I don’t find anything that mentions “pressure” or “sensitivity” or something there.

  • *sudo libinput measure touchpad-pressure --touch-thresholds=10:8 --palm-threshold=20
    *: I tried different values, but could not notice any difference in how the touchpad behaves. What I could see: the touchpad reacts already when the pressure is about “10”, and my goal seems to be that it reacts from a pressure between “80” - “100”.

  • I installed python-libevdev and python-pyudev for libevdev. And I created a file psmouse.modprobe in /etc/modprobe.d/ with the content “options psmouse proto=any”.

  • Then I installed gpointing-device-settings from the AUR. As the name sways, it’s a setting programme for the touchpad, almost the same as the one in the XFCE settings. It doesn’t have a sensitivitiy option either.

  • In /home/markus/.config/xfce4/xfconf/xfce-perchannel-xml/ there is the file pointers.xml. Maybe that contains some setting. But after messing around with the things above I rather don’t want to fiddle with this file without knowing what I am doing :upside_down_face:.

  1. Is there a way for me to make my touchpad less sensitive, i.e. so that I need to apply more pressure to use it than right now?
  2. Can I safely uninstall gpointing-device-settings, delete the file psmouse.modprobe and remove the python-things?

Please let me know which more details and specifications you need, and I will post them.

1 Like

Hello @maqni
Do you have this file? 70-synaptics.conf?

cat /etc/X11/xorg.conf.d/70-synaptics.conf

Thanks for the quick reply!
No, I do not have this file.

2 Likes

When you say it’s too sensitive do you mean pressure sensitivity or the cursor is too fast on the screen?

1 Like

Pressure sensitivity.
The settings for making the cursor fast or slow are working fine.

1 Like

Here is some information on libinput. There is a link on the page to upstream documentation. I’m not an expert on any of this. My newer HP works on KDE plasma with no issues.

https://wiki.archlinux.org/index.php/Libinput#Change_touchpad_sensitivity

1 Like

$ sudo libinput measure touchpad-pressure
[sudo] Passwort:
Using AlpsPS/2 ALPS GlidePoint: /dev/input/event6

This is an interactive tool

Place a single finger on the touchpad to measure pressure values.
Check that:

  • touches subjectively perceived as down are tagged as down
  • touches with a thumb are tagged as thumb
  • touches with a palm are tagged as palm

If the touch states do not match the interaction, re-run
with --touch-thresholds=down:up using observed pressure values.
See --help for more options.

Press Ctrl+C to exit

±------------------------------------------------------------------------------+
| Thresh | 15 | 12 | 130 | 127 | |
±------------------------------------------------------------------------------+
| Touch | down | up | palm | thumb | min | max | p | avg | median |
±------------------------------------------------------------------------------+
| 5509 | x | x | | | 20 | 107 | 0 | 99 | 100 |
| 5510 | x | x | | | 10 | 97 | 0 | 74 | 85 |
| 5511 | | x | | | 10 | 12 | 0 | 11 | 11 |
| 5512 | x | x | | | 9 | 113 | 0 | 51 | 13 |
| 5513 | x | x | | | 74 | 124 | 0 | 117 | 118 |
| 5514 | x | x | | | 9 | 108 | 0 | 59 | 80 |
| 5515 | x | x | | | 9 | 89 | 0 | 55 | 78 |
±------------------------------------------------------------------------------+

The min and max values show the weakest and the strongest pressure for each time I am touching the touchpad. Touch numbers 5511 and 5515 were the accidental touches (i.e. the wobbling and jumping of the cursor) which happened when I removed my finger from the touchpad.

When I try

$ sudo libinput measure touchpad-pressure --touch-thresholds=10:8 --palm-threshold=20

with different values from 1 to 1000 for --touch-thresholds and --palm-threshold, nothing changes. The touchpad always reacts in the same way and the output that libinput gives is always similar.

1 Like

Did you look at the man page in terminal?

man libinput-measure-touchpad-pressure

1 Like

Here are two articles maybe that help to read. The second one is probably the better after reading the first. As i am no expert on this i can only give you some info which may help.

https://bill.harding.blog/2017/12/27/toward-a-linux-touchpad-as-smooth-as-macbook-pro/

https://bill.harding.blog/2018/01/07/linux-with-a-macbook-touchpad-feel-pt-2/

Edit: This is more for Linux on a Mac book Pro but the information may be helpful.

2 Likes

Thanks a lot. So for the option --touch-thresholds=“down:up”, “down” should be around 80 for my touchpad to work fine (and “up” probably around 60). But because it’s a debugging tool only, I can not set these values.

The manual contains some links which are not working. But I have found this website. It says

Pressure thresholds are not directly configurable by the user, rather it is planned that libinput provides custom pressure thresholds for each device where necessary.

Additionally there are instructions how to report a bug with pressure ranges. Does it mean that I need to report the pressure range as a bug and then the sensitivity will be adjusted in one of the next updates of libinput?

1 Like

Thanks for the links. I will look at them and try whether they help me fix the problem.

1 Like

I don’t know what to tell you as this is really out of my realm. It’s a libinput devs thing i guess. Maybe there are others that have some more info who use laptops and have found ways to deal with this. I’m mostly a desktop user although i do have a newer HP laptop and did deal with some issues getting tapping working on it.

1 Like

Now I’ve tried to create a bug report for libinput, but did not succeed.

Can I safely remove the libinput drivers for my touchpad and install synaptic drivers instead, as mentioned in the second link that ricklinux sent above?

I am also thinking of installing KDE Connect and control the mouse from my phone, but only if that doesn’t mess up my system (I have already made my Ubuntu installation slow and buggy by installing KDE Plasma next to the Gnome DE).

1 Like

I am trying to install synaptics drivers for my touchpad now similar to this short instruction: I installed xf86-input-synaptics and xf86-input-evdev and tried to remove xf86-input-libinput. But I could not remove it with the following error.

$ sudo pacman -Rs xf86-input-libinput
Prüfe Abhängigkeiten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen) :: Entfernen von xf86-input-libinput verletzt Abhängigkeit 'xf86-input-libinput', benötigt von xorg-server
(“removing xf86-input-libinput hurts dependency ‘xf86-input-libinput’”)

Anyone knows how I can remove it and get the synaptics driver working?

It is a dependency of xorg-server so i don’t think you want to remove it.

Edit: Check the installation section on the second page of that blog i posted the link to.

I have changed the numerical values of the files in /usr/share/X11/xorg.conf.d

$ ls
10-evdev.conf  10-quirks.conf  30-touchpad.conf  40-libinput.conf  70-synaptics.conf

to

10-quirks.conf  30-touchpad.conf  40-synaptics.conf  50-evdev.conf  70-libinput.conf

and moved the synaptics file as suggested in the article

$ sudo mv /usr/share/X11/xorg.conf.d/40-synaptics.conf /etc/X11/xorg.conf.d/10-synaptics.conf

… and it works. I am having the synaptics driver now. It’s working a lot better now, though still a little bit too sensitive. When I type $ xinput list-props "AlpsPS/2 ALPS GlidePoint", I can see an option “Synaptics Pressure Motion”. I will try to adjust it a bit more. Thank you so much for your help!

Still one thing concerning the second question of my first post: can I safely delete the file psmouse.modprobe I created in /etc/modprobe.d/ with the text “options psmouse proto=any”, or better keep it?

Thanks again and I am happy that it’s working now.

1 Like

I would just maybe test it first by commenting out what you added. That way you can uncomment it if you need it back. If eventually you don’t need it then you could get rid of it.

@maqni
So do you have a synaptics conf file now that it uses?

Edit: Try this in the synaptics conf file. It may or may not work.

Option "CoastingSpeed" "0"

Yes, I have a synaptics.conf file. And just added the line you suggested and rebooted.
Now the touchpad is working well and easy to use.

Wow… I’m impressed you were able to use some of the info to get it working okay. :+1: