Touchpad stops working after sleep

As title says, touchpad stops working after i wake up laptop from sleep. It’s behaving like it is unplugged. Only fix so far is to restart laptop. Tried with lts kernel, same results.

Disable TLP and see if that is causing it, then install tlpui and play with the settings.

Sadly, disabling tlp didn’t made any difference.
I noticed that this only happens on kde and actually only if i close the lid. If lid is open and laptop goes to sleep, after waking up, touchpad works normally.

1 Like

What about:

sudo  modprobe -r psmouse
#then
sudo modprobe psmouse

?

Tried, nothing happened :confused:

Well, out of ideas, soz :smiley:

1 Like

Did you solve the problem? I have the same issue on Endeavour OS Atlantis, GNOME 41.2
wayland and xorg. Touch pad not working after sleep and not recognized at least in settings.

The reboot doesn’t work eather, only shut down and turning on again, which is so annoying.

Unfortunately no, just disabled sleep as there is no other workaround, at least i couldn’t find one.

Yeah, I think I’ll do the same for now :frowning:
But an idea occured to me,I don’t have the swap area nor file, but i don’t have time to test it now.
Will try it in a weak or two, and share the results.

I’m having a somewhat similar issue on my Lenovo IdeaPad 5. Sometimes after booting, my touchpad won’t be detected, i.e. it’s not listed amongst the input devices in xinput. Rebooting helps, but it is fairly annoying.

I’ve read in the Arch wiki that this can happen on a different machine than my own, too: https://wiki.archlinux.org/title/Lenovo_IdeaPad_Flex_5_14alc05#Touchpad/Touchscreen
There’s a fix apparently, but it requires knowing the proper device name, which I don’t for my machine.

Perhaps this can help you and if it does, maybe you can tell me how you figured out the device name. Is it just part of the output from xinput?

https://neosmart.net/blog/2020/multi-touch-gestures-on-linux/
This article helped me, i installed xf86-input-synaptics because i know i have synaptic touchpad (i’ve seen synaptic drivers while on windows, don’t know how to check it on linux) and tested it and so far it’s working fine. Will test it more and tell if there’s hiccups.

EDIT: It’s not working :frowning:

I added i8042.reset i8042.nomux i8042.nopnp i8042.noloop
to GRUB_CMDLINE_LINUX_DEFAULT attribute in the file /etc/default/grub
Then I updated the grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg 

and on the next start everything worked flawlessly :smiley:
Here’s the links that helped me:
https://askubuntu.com/questions/525629/touchpad-is-not-recognized
https://bbs.archlinux.org/viewtopic.php?id=221386

1 Like

Mabe try this?

1 Like

Unfortunately that didn’t work as well. My guess it has to do something with plasma as it is only DE where this happens.
In any case, thank you for trying to help me. I am glad you fixed it.