Touchpad not working well

This is actually a good sign. It means nothing is wrong with your hardware.

The normal kernel (linux) is the latest version of the kernel that is deemed stable. The LTS kernel (linux-lts) is typically an older version of the kernel that will receive continuous support (security patches, etc.) from the kernel developers for a set period of time (2 years, if I’m not mistaken).

If you take a look at the LTS kernel, it is currently at version 6.6, which is an older version compared to linux stable, which is now at 6.7.4

The benefits of using the LTS kernel is that it is more tested and therefore less likely to break. This is obvious if you think about it. Let’s say for example that 6.6 was released in June 2023 whereas 6.7 was released in Jan 2024. More time has passed between the release date of 6.6 and now compared to that of 6.7. People have spent more time using and fixing bugs on 6.6 compared to the latter.

For now, you can try to install the lts kernel and then select it at boot. Test your touchpad again. If the issue is not present when you are using LTS, you have to file a bug report to let the kernel developers know about the regression so that they can fix it.

1 Like

well ok. so if understand correctly, I need to reinstall the OS and install LTS

What? No. Just install the linux-lts package.

sudo pacman -Syu linux-lts

If you are using a standard EOS installation, there will already be dracut hooks in place to regenerate your kernel images. After the installation, just reboot and select the lts kernel from the boot menu.

ha, ok.

hmm… so LTS runnig and the touchpad is basically all the time lagging/delayed…

so i am moving back to normal

Interesting. So the lag didn’t occur at all when you are inside the live environment, but it’s happening now after a fresh installation. This could be a configuration issue.

Have you tried tweaking these parameters and see if the issue goes away? For instance, if you decrease or increase the acceleration or minimum pressure, does the issue worsen or improve?

yeah i tried many options. Now i dont even have this window, since i uninstalled the drivers (or whatever it was…) so i just have this basic setup…


and regarding the life ISO - i was there only for like an hour … i cannot really do much there when i dont have anything installed on live ISO. Withing that hour it did not happened. But sometimes even here for an hour or two it all fine… But then it just startes misbehaving for couple of minutes… then again going to normal… really weird

Is it perhaps a power management issue?

The OP did mention that the issue only occurs when the laptop is plugged in, so this is a reasonable line of thought, though I must say that this is beyond my current level of knowledge. Other than test out different power profiles, I don’t have any ideas with regards to diagnosing power management issues. I’m not sure what tools KDE uses for power management and what power profiles are available, but usually there are three profile types: performance, balanced, and power-saving.

@nirvikalpa Does different power profiles change the touchpad behavior?

I have also heard of cases where faulty power supplies prevent the touchpad from working properly when the laptop is plugged in, though I’m honestly not sure if that’s the case here.

So to recap, currently the OP has:

  1. Updated his firmware.
  2. Tried out the LTS kernel, which surprisingly seemed to worsen the problem.
  3. Verified (somewhat) that the touchpad works fine in the Live Environment.
  4. Uninstalled xf86-input-synaptics in favor of libinput.

What is needed now is to find a state of the system where the touchpad does work properly and then compare the two states to identify the culprit. The problem is, other than the Live environment, there doesn’t seem to be any condition where the touchpad does work.

@nirvikalpa At the moment, I can only think of two things since I’m running low on sleep:

  1. Downgrade to an older kernel version in order to test the touchpad. LTS 6.1 is still in the repo, I think.
  2. Go to Lenovo’s forums and find out if other users of the same laptop model is experiencing the same problem on Linux.
1 Like

yes i have tried different power management profiles. no effect. it does the same bad thing on each. I alsow tried different desktops (not only KDE) also no effect.

The problem seems to be somewhere hidden…

I am thiking of reinstalling the Endevour again to try my luck… If it will not help, i will have to find a different OS

maybe also before reinstalling i can try to install full EOS on usb stick with all the software i need for regular work and check how it behaves

Before you do that, it might be worth it to try with an older version of the LTS kernel (e.g: version 6.1). You can do this with the downgrade command.

hmm… ok. and that means that after that i can never use pacman -Syu right?

You can use IGNOREPKG, but that’s moot if the touchpad doesn’t work even with an older kernel version. Test it out first.

btw, when the system is starting… i can see there are couple of errors - can it be in connection with the touchap issue?