Totolink wifi USB driver A650USM


I just moved from Windows to Endeavour OS. My laptop is old and has a broken wifi adapter, so I must use a wifi USB to connect to the internet.

The USB works fine on Windows 10 but it is not registered by Linux. I searched for am official Linux driver but none can be found.

Can I fix this problem to get it working?

Thank you very much for the help.

Can you check whether your USB driver is visible by running the following command :


1 Like

I tried this. It only shows the webcam, linux root hubs, intel rate matching hub. No Totolink devices found.

Edit: Oh, i tried plug unplug and it shows 1 more: Realtek Semiconductor Corp. 802.11ac NIC

1 Like

Did you ran it after connecting your USB driver ?

1 Like

Yes, it is showing Realtek Semiconductor Corp. 802.11ac NIC

1 Like

I found an article which is discussing about the related issue. Check whether it helps.

Meanwhile, I will try to find more informations.

In this article, the author had discussed about installing driver based on realtek.

1 Like

Thank you so much. I’m checking the steps here.

1 Like

I found something more.

Let us know about the results after you go through the process.

If it shows the adapter then run

inxi -Na

Edit: If we determine what chipset it has because it also could be something else. If it is an rtl88x2bu then you can try the AUR package.

yay -S rtl88x2bu-dkms-git