Today's kernel update: monitor/display defaults to 1024x768

After today’s kernel update, the monitor/display defaults to 1024x768 with no other options for my current monitor resolution.

It was working fine before the update. I did power off, reboot, no change.

I don’t know how to fix this.

Thanks in advance for any help.

Keith

Execute the command line and post the output:

lspci -nnk | grep -i "VGA\|'Kern'\|3D\|Display" -A3

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
	DeviceName:  Onboard IGD
	Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller [1028:047e]
	Kernel driver in use: i915
--
00:16.3 Serial controller [0700]: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller [8086:1c3d] (rev 04)
	Subsystem: Dell 6 Series/C200 Series Chipset Family KT Controller [1028:047e]
	Kernel driver in use: serial
00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) [8086:1502] (rev 04)

I rather expected the problem kid proprietary nvidia driver.

Well, the driver is loaded successfully. You could write a .conf-file:

$ sudo mkdir -p /usr/share/X11/xorg.conf.d/
$ sudo -H leafpad /usr/share/X11/xorg.conf.d/20-intel.conf

Insert:

Section "Device"
	Identifier	"Sandy Bridge IGP"
	Driver		"i915"
	Screen		0
EndSection

Section "Monitor"
	Identifier	"FHD"
	Option		"PreferredMode"	"1920x1080"
	Gamma		1
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Sandy Bridge IGP"
	Monitor		"FHD"
	DefaultDepth	24
	SubSection "Display"
		Virtual 1920	1080
		Depth	24
		Modes	"1920x1080@60"	"1366x768@60"
	EndSubSection
EndSection

Of course you have to set the native resolution of your TFT (in this example 1920x1080).

@axt

OK, I added this, making sure the resolutions matched the monitor.

Shutdown. Power up, it hangs at “/dev/sda1:clean…(files)…(blocks).”

I’ll have to go back in with a live disc later to delete it.

Keith

The message comes from fsck being run at boot time.

You should make sure to copy and paste all of it.

Could you the output of command

lspci -vnn | grep -wP '0300|0302|0380'

manuel, we already have this information. :wink:

True, was too hasty reader…

That is all of it, except for the digits. The cursor goes to the next line and that’s it.

I gave it 20 minutes and it did not change.

Did you try using the other kernel, linux-lts? Worth a try if you didn’t.

I mean c&p 20-intel.conf. Do not write-off, always copy & paste!

After a lot of tweaking, testing, swapping out monitors (four different monitors, four different resolutions, four different manufactures), fresh OS installs of various distros, I finally noticed THIS:

I turned on the Connecting Displays switches.

So, for the past couple of days, with a couple of different distros, the proper resolutions are detected.
(I probably just jinxed myself by saying this. ^)

  • I’m still not convinced this is THE fix.

In my opinion, THE problem is this machine, an old Dell Optiplex I recently aquired. This is the first “factory” computer I’ve ever had. I’ve always built my desktops from hand-selected parts and have never experienced anything like this before.

NoDisplay=Dell

Never again

Great that you found the reason! :+1:
It is sometimes quite hard, as there are so many potential reasons.

1 Like

It’s Dellified! :laughing:

1 Like