[Tip] Panel Translucency in KDE Plasma without Kvantum

You don’t need Kvantum to have panel translucency in KDE Plasma. The default theme supports it, but sometimes it is disabled by default.

To enable it, edit the following file using Kate:


Under [ContrastEffect] comment out the line that says: enabled=true by adding an octothorpe (#) in front of it, and add the line that says: enabled=false (or you can just change true to false, but you’ll forget you did that if you ever want to revert it). So it should be something like this:


Save the file (you will be prompted to enter your sudo password).

That’s it, panels and the application launcher should now be translucent (if they are set to be translucent, and compositing is enabled). To change the blur, go to:

System Settings → Workspace Behaviour → Desktop Effects → Blur

and click on the “Configure…” button next to it. Lowering the blur and noise strength will make translucency of the panels more obvious.

Also, you can change the transparency of any window (including panels) on the fly, using the mouse wheel. To set that up, go to:

System Settings → Window Management → Window Behaviour → Window Actions

and under “Inner Window, Titlebar and Frame Actions” select a modifier key (I like to use Meta for this) and under "Mouse wheel: " select “Change opacity”.


Hmm, can’t seem to get that to work.

Relevant bit of /usr/share/plasma/desktoptheme/default/metadata.desktop:

#intensity is disabled, in order to auto adjust to the chosen theme color


Do I need to comment contrast=0.2 as well?

Blur settings:


(So nothing pertaining to the Application Menu or the panel.)


Panel settings:

Try reducing blur strength to zero, and place a high contrast image (or some text) behind the application launcher or the panel. Perhaps the translucency is just very subtle.

I think I see a weeeeeeeeeeeeeeeeeeeeee bit there…I suppose the second part of your post is where I’ll get to set the actual translucency?

Is it supposed to take effect immediately, by the way, or does it require logout-login?

1 Like

Well, kinda sorta. Temporarily. That trick works, but it’s reset upon closing the window and reopening it. Is that its intended behaviour? Sidenote, do that on the Application Menu and it only affects the part of the menu the pointer hovers over, not (sub)menus your pointer isn’t touching; quite the funny effect indeed!

Translucency of panels has nothing to do with transparency (which you can set permanently using Window Rules).

Translucency is a very subtle effect. I have not found a way to increase it. But with a high-contrast background, it is quite noticeable:

BTW: I hate this new Application Launcher, but here it demonstrates translucency rather nicely.

Right-click it, Show Alternatives... lets you pick something else, like the Application Menu I’m using, perhaps you like that better :slight_smile:

BTW, I had never even heard of Kvantum and none of this was something I saw as an issue, I just figured it’d be fun to play with, and it was. Thanks for that :slight_smile:

1 Like