Timeshift - won't run on its own

Greetings. First, I owe major kudos and gratitude to all who make our computing experiences so phenomenal. As is often said: We stand on the shoulders of giants.

My issue with Timeshift (v22.11.1-1) is minor, but puzzling…

Context: I’ve used Timeshift successfully for over a year (it’s saved my bacon more than once!) - running under Manjaro/KDE and, more recently, with EndeavourOS/KDE.

But since making the break to i3wm (EOS) with nnn… I’m stumped.

Yes, I can manually run Timeshift (“O = on demand”) with no issues. But it will not run on its own.

I can get it to run nicely by with sudo timeshift --check - in which case it knows that it was “supposed” to run hourly, daily, weekly, etc., since it reports all this in terminal, while it “catches up” with an updated backup.

But unless I either invoke sudo timeshift --check or use the timeshift-launcher GUI app, Timeshift will not take it upon itself to run again. I’ve left it alone for over 48 hours & more to confirm it’s not doing it’s thing. (Along with 2 boots, 1 daily, 1 weekly, 1 monthly, I’ve requested it keep 3 hourly backups - but nothing gets done without my manual intervention.)

I have confirmed entries in /etc/cron.d/timeshift-boot and /etc/cron.d/timeshift-hourly which match those frequency choices I’ve made in Timeshift’s “Schedule” screen.

I’ve done a lot of searching here and elsewhere and have tried a number of dead-ends. Nothing works thus far, except performing manual backups. BTW, I’m using Timeshift only for system backup, not my home directory stuff. (Meanwhile, Vorta/Borg is working perfectly with hourly backups on its own for my ~/home/ejm directory.)

Any ideas to solve this conundrum would be appreciated.

You need to enable the cron.

systemctl enable --now cronie

It isn’t enabled by default since most things use systemd timers these days.


If you want to stick with systemd, you can install this AUR package: timeshift-systemd-timer. I didn’t realize that timeshift itself was only available via the AUR.

1 Like

While I have no strong feelings re: systemd (should one?), I’ve just installed timeshift-systemd-timer per your suggestion and will report back. Thanks!

Thank you … will keep this approach in mind. Since I’ve just yay’ed timeshift-systemd-timer (per above) and rebooted, I’ll give that a chance to see if it can do its magic.

You should verify that the timeshift timers installed by the package were actually enabled.

1 Like

I’m assuming they were (since the cron entries are present) but is there some other way to confirm they’ve been effectively enabled?

You may need to systemctl enable -now whatever.timer the timer file that package dropped on your system. The package installation may not have enabled and started the timer.

The package installs the following timers and services:


for taking snapshots at boot and hourly. Is that the frequency of how you want to make Timeshift to take the snapshots? If so, that’s fine then.

Edit: nevermind, just reread your op:

i’m by no means trying to be a jerk but timeshift NEVER worked properly for me. i sorta hate it… after how many times i lost data from it. errrrrrrrrrrrrrr…

i no longer rely on it.

Man, you nailed it! Thank you very much for aiming me in this direction. First I checked “status” and saw it was not enabled. Then followed your lead, confirmed enabled status, rebooted for good measure, and Timeshift has begun doing its thing without my nagging :wink:

Bonus: I also put a toe deeper into systemctl usage, and stumbled upon systemd haters out there (https://without-systemd.org/wiki/index_php/Arguments_against_systemd/)

Interesting side topic.

Indeed, that was my problem. Per @dalto’s more detailed reply I was able to get this solved. Thank you, too!

1 Like

Interesting. Sorry to hear it has failed you. I’ve been bailed out by Timeshift’s system backup capabilities on several occasions now, on various Arch setups, so I am very thankful for it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.