Timeshift and EFI

I’m dual booting EOS with Windows (UEFI and systemd boot). I’ve installed Timeshift and after a first snapshot with rsync, I noticed it’s not backing up the EFI partition mounted as /efi.

  1. how do I force Timeshift to backup this directory?
  2. how do I manage restore of this partition if I have to?

If you dual boot Arch Linux and Windows, your /boot partition is outside the / partition. This answers your question why the /efi directory is not backed up. You can back up your root directory and your home directory. I also assume that you do not have a btrfs system, which is why you use rsync. Normally one mounts the EFI partition as /boot/efi. I use btrfs, it is better and gives you more finesse when using timeshift. Rsync snapshots contain only those files and directories that have been changed or modified.

To restore the /efi partition you boot into arch using the install disk, mount the /root and /efi partitions and then chroot. That would be the way.

1 Like

your /boot partition is outside the / partition

So there’s no way to backup a mounted partition?

Normally one mounts the EFI partition as /boot/efi.

The EOS installer suggested /efi (so it’s mounted like that on my system).

Rsync snapshots contain only those files and directories that have been changed or modified.

I wonder if Timeshift is smart enough to restore everything (not just the files in the snapshot) when using rsync?

To restore the /efi partition you boot into arch…

To do that, I first need a backup of that partition :slight_smile:

Why not rsync your EFI partition by hand? Or write a simple script? Timeshift is limited in it’s use and many people say, it is NOT a backup-program for the exact same reason you are posting your problem.

There are other tools around for that, too.

1 Like

The ESP on a default installation of EnOS with systemd-boot is not bigger than 1G.

You have the option to make .img file of it as well.

An application like gnome-disk-utility can do that easily. It’s a Gnome app but it is minimal on dependencies.

1 Like

I’m already using rsync (with grsync) to backup my home directory. I was hoping that Timeshift is a bit smarter with system backups as I’m still not sold to btrfs snapshots…

Can’t say. - The “path” (without using Tombshift) should be clear now?

I just made an rsync snapshot of my system with Timeshift.

My ESP is mounted at /boot/efi.
I can verify that the content of my efi folder residing on that partition is all there.

So I don’t really understand the issue here.

If you make an snapshot and choose to include all the files in root, then the content of efi directory should also be included. If it is not, go to settings and Filters tab. At the bottom click on Add Folders and add whatever folders you want to be included in the snapshot.


I already tried to add /efi folder : directory is created but empty.

You shouldn’t do that. - Delete the folder again, before rebooting, please.

Next, please post the output of this:
lsblk -f

And this:
cat /etc/fstab

…and mark the pasted output from your terminal and format it as code, using the symbol </> in your post-editor.


I meant, the efi directory is created in the snapshot folder of the Timeshift backup but it’s empty there (don’t worry, the efi partition is intact).