Tilde button

I use tilde button (left of number 1 on keyboard) as push to talk keybind in games.

In Windows it works perfectly, but on Linux I have to use the alt gr + tilde button combination in order to get it to work.

Is there something I can do to get it working without alt gr combination?

You may need to change the keymap; mine is French, and there are several variations on how that key, and some others, are handled. During EOS installation, Calamares lets you test your keyboard in a text field to see how the more bizarre keys are handled.

But before that, while in-game, can’t you rebind the talk key, and see what comes out when you push that key (without modifier) and offer it as binding ? Is the key recognised at all ?

Also note that different games will handle the keyboard in different ways. Some will completely ignore the local keymap, some will respect it, and every strange combination in between.

1 Like

I selected German keyboard layout during EOS installation.
When I press that “tilde” button right now when writing this, it works as intended: ^. It functions exactly like on Windows now.

I tried it out now in few games and the result is always the same:
The game recognizes the button when I want to change keybindings:
image
But when actually pressing it in the game, nothing happens unless I use the alt gr combination with it.

Why not use alphabets or lower case symbols like " \ " ?

Because I’ve always used this and I’m used to it.
Also / doesn’t make sense to me because we probably have different keyboard layout. It is not practical for me to use that key.

There is some error…

I told about /

Edited it out now. Yeah, I know what character you meant.

For me, ^ is a modifier for “accents circonflexes” (êôî…). I have to hit the corresponding key twice to get the ^ symbol.

Since it is a modifier, it is not necessarily always handled like a symbol like ~ or ² (the latter being what’s bound to that physical key you’re interested in, in the fr layout)

To establish that your problem stems from the layout, try switching to fr; you’ll get ² in text fields for that key; try binding it in game, and using it. Odd are, it’ll work. I often bind stuff to that key in game, and most games i’ve tried it in recognise it.

If it does, then the next step will be finding a german layout for you with ~ or ² or anything sensible bound to that key.

Yeah it’s because of the keyboard layout.
Thanks for troubleshooting it. Will definitely need to rebind to some other key because I don’t want to change my keyboard layout just to make the button work properly in games.

It’s not that big of a deal ! For French, for instance, there are about 20 different layouts available. But they’re all AZERTY. They are mostly minor regional variations, and slightly different takes on the special keys, like the one you want. The core of those layouts is all the same.

All you need is a variant german layout that differs from the one you’re using only on that key and maybe a few other odd ones like that. I’ll take a look.

1 Like

Ok, try switching to the deadacute variant of “de”. You should have:

$ setxkbmap -query
rules: evdev
model: pc105
layout: de
variant: deadacute

The difference is that <^> followed by <E> produces ^E and not Ê. You should be able to bind on the ^ symbol correctly.

1 Like

Wonderful! Thanks a lot. This was actually the case.
It works perfectly with German (dead acute) layout.

I’ve marked your other post as solution because it explains more into detail what needs to be done.

Perfect. Have fun !

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.