Thunar fails to mount internal NTFS HDD: "wrong fs type, bad option, bad superblock on /dev/sdc1, missing codepage or helper program, or other error."

image

Hello, I get the above error when trying to mount an internal NTFS HDD using Thunar after entering my password.

If I mount via ‘sudo mount /dev/sdc1 /mnt/Video’ it mounts as expected (same if I specify -t ntfs). If I mount using ‘sudo mount -t ext4 /dev/sdc1 /mnt/Video’ I get the wrong fs type error, so I presume Thunar is trying to mount using the wrong type.

If I add the drive into /etc/fstab as ntfs all works as expected - is there any way I can specify mount options in Thunar?

Thanks

If the above question is the actual question/issue, please change your post topic to it.

As far as an answer is concerned: Based on the Thunar man page, no, you can’t do this. However, the Arch wiki shows that there’s a lot that Thunar can do. Go here: https://wiki.archlinux.org/title/Thunar, press CTRL+F, then type “mount” to review Thunar’s mounting capabilities.

Also, based on the man page for mount, the “-t” parameter is used to limit the filesystem type to something specific. If you have an NTFS partition and try to make it mount as ext4, it wouldn’t (and didn’t) work.

Try replacing ext4 with vfat instead.

Check here for more: https://man.archlinux.org/man/mount.8

This was the first google result when i searched my issue, but your issue was exactly what i was seeing too. Apparently it’s an issue with ntfs3 vs ntfs-3g. blacklisting ntfs3 fixed the issue for me. https://bbs.archlinux.org/viewtopic.php?pid=2122577#p2122577