Thunar, Archive Manager slow startup

Hey all,

Been using endevouros i3wm edition for awhile now (maybe a year?) and loving the experience.

However, the past week or so I noticed that launching thunar and archive manager are take incredibly long to startup, mayb almost 20 secs or so… which is unusual as this was not the case before…

I have gone through various forums including this one looking for an answer but non of the solutions I came across helped so far…

What I notice is when launching either thunar, or archive manager using root, they launch immediately. The delay only seems to happen when I am launching the apps as a user.

Furthermore, after they are launched they seem to work normally until I close all instances of thunar or archive manager. Then we are back to the slow startup of launching a new instance.

Has anyone faced similar issues and found a solution?

Things I have tried so far:

  • editing /usr/share/gvfs/mounts/network.mount and change AutoMount=true to AutoMount=false
  • clearing ~/.cache/thumbnails
  • removing any themes / icons that I had applied previously
  • adding read/write permission to my group in thunar by navigating to file -> properties -> permissions in thunar

Also if you need me to provide any more info, do let me know and I will be glad to share…


1 Like

I do have flatpak installed and I read somewhere that removing xdg-desktop-portal helped solved a similar issue somebody was facing.

However, I do use flatpak for some applications and uninstalling xdg-desktop-portal is not an option as it seems to be a dependency of flatpak

at-spi2-core could be culprit:

also reports about thunar… but it says when starting thunar in admin mode…
But if the cause it should be fine wuth latest updates…
I do not have any lag with thunar here on different installs…

@joekamprad thanks for your quick response.

edited: found out the version using pacman -Q | grep "at-spi"

This is the current version installed on my system: at-spi2-core 2.48.2-1

Looks like I have the latest? Issue still persists tho…

I have tried downgrading as well to version 2.48.0 but to no avail…

I don’t understand the purpose of starting a thunarflatpak as root.
No matter if it was installed system wide or only for one user.
System files are blacklisted according to Flatpak’s documentation.

Hence my question. I could imagine that now certain file permissions are confused.


I may have misunderstood your comment, but my mention of Flatpak earlier is because I found a thread online where somebody suggested uninstalling xdg-desktop-portal as a fix to a very similar issue he was facing with thunar.

In my case Thunar was installed by default with endevouros and I am not using thunarflatpak nor have I started it as root.

I only mentioned it because I uninstalling xdg-desktop-portal is not possible as it is a dependency of flatpak.

I hope this clarifies things? unless I have missed the point of your comment completely lol…

Now I understand. :muscle:

It was about xdg-desktop-portal-gnome
So if you have this one installed as well, you could remove it.
Flatpak will work with xdg-desktop-portal.



bro, I love you…

uninstalled xdg-desktop-portal-gnome and it worked immediately.

marking your post as the solution incase anyone else stumbles upon this in the future…

1 Like

Glad you got it working!
:enos: :wave:t5:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.