This Session is Locked

This just started today.

Sometimes, when my laptop has been sitting idle and it goes to sleep and I wake it back up, I get a black screen with the following message:

“This Session is Locked
You will be redirected to the login screen in a few seconds.”

The problem is, that statement is not true. I do NOT get redirected to the screen to put in my password and resume my session. I never get redirected any where at all. The only way to recover from this state that I have found is to hold down the power button on my T450 and until the laptop powers down and then turn it back on.

Has anyone else seen this? How can I stop this from happening?

I haven’t seen this exact problem personally but here is what I always do on all computers running the Xfce DE (regardless of the operating system):

Go into the Settings Manager and go to Screensaver. DISABLE the screen saver AND in the Lock Screen tab DISABLE everything there too.

Then, still within the Settings Manager, go to Power Manager and set the settings like this: When power button is pressed, shut down. Sleep button, hibernate button, battery button should be set to Do nothing. When laptop lid is closed, setting should be set to Switch off display.

Under the Security tab, set Automatically Lock Session to Never. Also Uncheck Lock Screen When System is Going to Sleep.

All the above ought to take care of your problem.

At least I hope it does! Please let me know.

Lawrence

I agree with you except I don’t have an issue with the screen saver. Definately no sleep or hibernation. Just shutdown the screen. Even my new desktop doesn’t work with sleep or hibernation even on Windows. Some hardware does but a lot don’t.

Same thing happened to me this morning. I simply uninstalled the xfce power manager since it is annoying at best on a desktop computer. That is not a good option on a laptop, though.

Follow this thread on arch for more info: https://bbs.archlinux.org/viewtopic.php?id=249053

Well, I still suggest that you just change the Power Manager and Screensaver settings anyway, just as I described. I think that changing those settings will eliminate your problem.

If that does not, however, it is easy to reset the Power Manager and Screen Saver settings back to their defaults.

You have nothing to lose by trying my suggestions …

Lawrence

I don’t have a problem i was just agreeing with you. I’m just saying the screen saver doesn’t seem to be a issue for me anyway. :blush:
Not all hardware works the same but some think it should just do what they want it to. Not!

I can’t seem to find the screensaver settings in the Settings Manager.

Are you using the Xfce Desktop Environment? If so, and if you have pamac-aur-git installed, do a search for xfce screensaver and, if it is not installed (and you want it), just install it. (The current version is 0.1.8-2.) Then it should appear within the Settings Manager and you can adjust it to your liking.

I hope that this helps you.

Lawrence

I think that your lockup problem may be able to be solved by turning off everything in the Lock Screen tab found in the Screensaver settings. That is the tab to the right of the Screensaver tab (in the Screensaver settings in the Settings Manager). (I assume that you are using the Xfce DE.)

Please pardon me if you have determined that these settings are not the cause of your computer locking up (for no apparent reason).

You’re right about hardware working - I’m afraid that hardware will not adjust to one’s particular liking; one must adjust him or herself to the hardware requirements (as much of a pain as that often is!).

I have turned off everything in both tabs in the screensaver settings. I do not want my computer to be turned off or locked up unless I myself do it manually. Of course, that’s just my own preference.

Lawrence

1 Like

what say:

pacman -Q light-locker >& /dev/null && echo yes || echo no
?

1 Like