Thermal Monitor plasmoid can't see lm_sensors

Hello. I tried to configure EndeavourOS and have a problem - widget can’t see any sensors. And some over resourse monitors have a same problem.
lm_sensors installed and configured. “sensors” work correct, xsensors too.

Where can be a problem?

Have you tried another widget with the same function, just to rule out that it isn’t the widget that is faulty?

Welcome to the forum, by the way.

Yes, I tried also “Resourses monitor” and “system load viewer” and them doesn’t work. But, native “system monitor” work well.

I’m trying to switch from manjaro, and already have familiar and convenient widgets setup, which I want to repeat.

P.S. Thank you :slight_smile:

These are just two shots in the dark, since it is working on Manjaro. Try:

  • Switch to Xorg or Wayland, whatever you’re departing from now.

  • Try the Linux-LTS kernel

I have the Thermal Monitor plasmoid working fine on xorg, with any kernel.

How did you install it? If you installed by clicking on the “Get more widgets…”, you should uninstall it and install the repo package named

plasma5-applets-thermal-monitor

I also have the following packages installed:

lib32-lm_sensors
lm_sensors
qt5-sensors

Also, the drop down menu in the Edit Resource dialog is broken on dark themes (it displays white text on white background). But it works nevertheless, it’s just a graphical bug.

Is this just for laptops?

Thank for for the detailed answer.
I had

lm_sensors
qt5-sensors

and widget, installed from “Get more widgets…”.

After your answer I added

lib32-lm_sensors

and tried repo package

plasma5-applets-thermal-monitor

And nothing changed.

After, I download and compile widget from original github

and he still can’t see the sensors.

It seems to me that some kind of transition package is missing between lm_sensors and widgets.

This could help. I was having the same problem before:

  • yay -S plasma5-applets-thermal-monitor-git
  • sudo pacman -S ksysguard

Source: https://aur.archlinux.org/packages/plasma5-applets-thermal-monitor-git/#pinned-813008

Thank you! Installing ksysguard really helped.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.