There's no internet in installation. No dialogue installation box. Also after powering off, it'll never shutdown

My specs:
i7 9700k
b360n wifi (MoBo)
32gb ram adata xpg flame (16x2)
Nvidia RTX 2060 FE

Well. My problem is that, after creating the ISO pendrive with ventoy (used rufus too) with the ISO of EndeavourOS. I selected the option of world-wide (github) to download the ISO.
-Tried to install it. But it was impossible, there was not window that can show me the installation dialogue.
-There was also no internet. I have a Ethernet cable, and the ISO cannot detect it. It’s what I use mostly, a cable ethernet. But I also wanted to try WiFi. It wasn’t detected too. After some time, it showed me a dialogue like “Internet connection not available!”
-After powering off, the machine just won’t shut down. It got stuck at the end.

Tried other options, like choosing open source drivers at the start, changing Ventoy to gpt, using rufus to create the image as gpt. Trying to not start with UEFI in boot options, but with mbr in ventoy (or rufus, I don’t remember), I downloaded the ISO from other sources, alternatives for world-wide in the official page, changed things in my BIOS…
I tried a lot of things, selecting other options and it was the same drill: No dialogue, no internet, cannot shut down correctly.

Then I was just thinking. Is the download broken, is it my location? What’s the matter? I’m searching and cannot find solution. What do I need to put in the terminal?
Then, I watched my old notebook. Gateway ne46r05m. The ram was upgraded: Intel Celeron B820, 4gb ram. I just put how I had the usb originally, ventoy mbr, same ISO. IT WORKED LIKE A CHARM! Finally!
Had all the dialogues, the wifi was working. After powering off, all was good. In the beginning to the end all was smooth and nice.

The problem is not a bad download. I tried other sources to download the ISO in the official page of EndeavourOS. The problem itself could be the ISO or hardware compatibility with it.
I think, could be the compatibility of my MoBo/BIOS, but every distro works pretty good with default settings in my bios. So, yeah… maybe the mistake could the ISO itself. Remember, I downloaded from other sources, but I mostly used the world-wide (github) option. Generic ventoy installation works fine with most distros I used.

Guys. I just feel pretty bad. I really wanted to install it. A lot of people recommended me this distro so so much.

Some pics:
No internet connection.


Stuck at the end.

What is you network card?

inxi -Na

Edit: https://discovery.endeavouros.com/network/r8168-workaround/2021/03/

Two thoughts. As for the internet, try connecting to WiFi so that you can do an online install. You might have better luck with the wired connection on full install. For the shutdown issue, it seems like there are some specific sweet spots with different computers (BIOS) and desktop environments. Sometimes a “sudo shutdown now” works perfectly from a terminal, and other times it works better from desktop. Other times, adding -r to the shutdown now will work fine. Not that you want to do that, but at least you can get into UEFI or BIOS where it is safe to hard power down and not have to kill a running process. I would recommend trying the “sudo shutdown now” from terminal.

Thank you for shutdown command. Sadly, as I said above, it’s not possible for me to use ethernet nor wifi. The dialogue installation is not even showing.

Use USB tethering from your phone

Network card?
I only have this in my MoBo:

  1. 2 x Intel® GbE LAN chips (10/100/1000 Mbit)
  2. Intel® CNVi interface 802.11a/b/g/n/ac, supporting 2.4/5 GHz Dual-Band

I think this is too much for just installing a simple distro. I heard a lot of beautiful things of Endeavour, but it’s impossible for me to install it.

In the end, endeavour is just Arch.


Bro. Terminal stuck after the command.

It is not impossible. There is just some issue with either your hardware or the live ISO. Because you are unable to get internet it is difficult to provide critical information that would help. If you are able to boot on another distro it would be nice to see inxi -Na to look at what chip this is. I create my live ISO with etcher on Windows. I use to use it on linux but now i use popsicle on EndeavourOS. Don’t give up. Try to create another live ISO with etcher. It would be nice if you could get inxi -Fz --no-host also.

Use systemctl reboot.

Yeah, it is hanging at the same place as using the desktop shutdown. Too bad this issue happens on a ton of distros/desktops and with various kernels/bios with no resolution. I have one computer that is a 50/50 wether it hangs on completing power down cycle, one that the terminal command works but completely hangs on desktop shutdown, and one that hangs on shutdown now -r or if if I try to restart from desktop instead of fully shutting down and starting back up. If the shutdown not -r or or restart works, you can always go back into bios and hard shutdown from there. At lease hard shutdown from bios is safe for data.

The fact that it seems to work fine on another system suggests that it is hardware specific. Have you been through the BIOS to ensure that no settings are impacting your experience? No fast boot, no CSM, no secure boot etc etc…? Have you got overclocking intended settings enabled - they can cause instability if not well tested…?

The ISO works on a wide variety of setups without issue (and quickly too!) so something is interfering. Before hitting the install, have you also tried using Welcome to set your ethernet interface driver?

Thoughts for possibilities…


Same thing. Stuck :frowning:

Hmm. Interesting. My monitor is a MSI Optix Mag24c
This monitor does not have driver itself. When I used to use windows, the driver was always generic. The official page of MSI does not package an official drover for it.
I don’t know if this can help.

Edited: btw, I’ll try to use another monitor

I remember I put everything in my settings. No matter if I disabled or enabled CSM nor secure boot, for most gnu/linux distros I didn’t see a bad impact installing with or without those settings. And using linux in general with or without it.
Although. By some linux wikis and recommendations from other users, I use disabled both CSM & secure boot.
And using the option of “Other OS” too instead of “windows 10/8 features”.

I don’t have nothing overcloked nor undervolting, or something. Just using the default parameters of my MoBo. I remember I set default things and just changed the things of CSM/secure boot

My MoBo is a Gigabyte b360n wifi

Also, it’s impossible to start the welcome app. In my laptop, by default it’s showing in the screen. But in my PC it is impossible to start it. Even if I click on the app.

I’ll se what I can do. Thank God I have several distros on my USB that I can install without problems no matter the settings on my pc… Even arch-based ones.
I’ll put them on terminal and tell you what I see :wink:

I downgraded my BIOS from 15b to 14 version.
The same drill. I was thinking if it was the fault of my BIOS version. But no. Is the same thing.


No Internet (no wifi nor ethernet). No welcome interface, even if I try to start it from the menu it is not showing up. And it cannot shutdown the system properly.

Have you done a memtest, to verify your RAM?
Have you looked at the logs with journalctl -xe to see if it tells you anything about Calamares’ failure to run?
Regarding shutdown : https://discovery.endeavouros.com/acpi-kernel-parameters/acpi-kernel-parameters-and-how-to-choose-them/2021/03/ may help eventually.