The upgrade to Kernel 6.1.12 stopped the system from working

On my Lenovo Legion laptop, (Ryzen 5600H, rx 6600m) the system only kind of boots after upgrading to the latest kernels. (linux and linux-zen 6.1.12) I get into plasma, but nothing really loads, in tty nothing really works, either. Downgrading partially fixed the issue, left me with no internet access, though.
linux-lts works just fine.

Here are links to screen recordings I did with my phone:
Trying normal linux kernel:

Trying linux-zen kernel:

There’s probably a better way to read whatever it says, but I was in a hurry. I’d be glad to add that information, if you tell me how.

Firstly, awesome computer! I love mine! You may just need the LTS kernel for a few days. (Mine is on Fedora, so I’m still on 6.1.11 and it’s ok so far)


Thank you! Yeah, my PC is on 6.1.11 as well, I’m glad I caught it on my laptop tbh.

great, now LTS also stopped working after an update

You’d have to provide more info for someone to be helpful.
Like this, e.g.
inxi -Fxxxrza | eos-sendlog

Also, please check out the EndeavourOS-Wiki for further info that might be helpful, such as boot-logs, pacman-logs, etc. to understand and identify any issues you’re having more clearly.

I’d do that, if I could do anything. Unfortunately, almost nothing seems to run, even in LTS after updating

I mean, are they still the same kernel or did one of the maintainers finally figure out that there may be some reasoning why it might be good to have 2 different kernels available for folks?

edit: I just checked. They are still the same lol. :persevere: Both latest and lts are 6.1 . . . so you may need to see about trying a different kernel until the 6.2 comes out finally. I’d try and go back to 5.15 if everything was working well for you.

So you could arch-chroot into the broken system from a live ISO and repair your system, or send logs to this forum from within the chroot environment.

Check the EnOS-Wiki for that here & here.



about what we can see ,there is a kernel panic in both case about

but all version are 6.1.12
current , LTS and Zen

→ new versions for all …

1 Like

While I didn’t repair it, because I needed to use it and no meaningful data was stored on it, I reinstalled Endeavour OS. Since that worked fine on 6.1.12, it must’ve been something else, that broke on some change in the kernel. Kind of weird, considering I didn’t install anything considered exotic, but hey, at least it worked.

Thanks for the help, though. Should it break again in the future, I’ll know what to do then.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.