"The script failed with error None" during install


I am running into a very troublesome problem. every time I try to do a online install for KDE I get this error to pop up during the install in the boot loader stage:

“The script failed with error None”

I tried looking up this issue everywhere with not one other person having this exact problem before! With the error quite literally returning “None” I had no lead so I decided to ask for help here. a bit inexperienced with Endeavour OS specifically and a tad experienced with Linux as a whole. I wanted to reinstall Endeavour OS since I wanted a fresh start.

I originally had the ISO on Ventoy, then I tried re-downloading the ISO, then I tried flashing it to a USB drive, then I also tried formatting the entire drive with no difference (I am dual booting with Windows 11 where I install Windows first, then Endeavour OS). I like the online version because I can disable and enable packages I want or don’t want very easily. Below I have linked the log of the installer. My guess is a broken package that was recently released since it crashes when doing the online install but someone with more experience made have a easier time figuring it out. Any lead is appreciated!

Thank you.


It is bug that we have fixed that will be in the next ISO.

For now, don’t remove welcome from the list and then just uninstall it after the install.


Thanks that works!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.