The /efi partition no longer works on reboot

Hi! This morning I installed eos in dual boot with windows 11, I created a new fat32 partition mounted on /efi, a root in btrfs and a swap, I configured the system to use systemd-boot and installed the Gnome version. Everything worked for half a day, then on the third reboot it stopped with an error I’ve never encountered and I can’t get it to start again. Not having access to the system, I report a photo of the error, I hope someone can help me because I had already configured the whole system according to my needs and I would be sorry to have to reinstall it. Thank you.

Enter the root password at the prompt and then type blkid and share the output.

It looks like the UUID for your EFI partition changed. Did you make any partition changes or change settings in the BIOS?

Either way, the solution is to:

  • Boot off the ISO
  • arch-chroot into your system(ensuring you mount the EFI partition at /mnt/efi)
  • Edit /etc/fstab with the correct UUID for your ESP
  • Run reinstall-kernels
  • Exit the chroot and reboot

I didn’t change anything, just turned it off and on again. I’ll try, thanks for the help!

Ok, the solution worked, and thank you so much for your precious help. Now I just have to understand why this happened, I would not have been following a kernel update. With systemd-boot, which I don’t know, if I update the kernel do I have to give reinstall-kernels after the update is complete? I remember that with grub I had to reload the configuration at the end of each kernel update, because otherwise the operating system would no longer load…

1 Like

With systemd-boot it is automatic.

As to why your UUID changed, I am not sure. That is often caused by a BIOS or disk change. For example, resetting or updating your BIOS.

Installing updates and/or rebooting shouldn’t cause a UUID to change.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.