The best way to implement reverse prime on an intel/nvidia hybrid graphics laptop endeavouros gnome

Is there a more recent guide to how to implement reverse prime on an intel/nvidia hybrid laptop

assuming i have freshly installed the gnome version of endeavour os?

thanks in advance :slight_smile:


The “best” guide would be the Arch wiki:

Also to note, with recent hardware and drivers reverse PRIME works automatically.

its so hard to follow my bro. lmao i might just be stupid.
I was able to get this to work on manjaro. but only because prime was already preinstalled. all i had to do was make the xorg.conf file
i think i need to start a bit further than that with EOS though

Which bit doesn’t work?

What hardware do you have?

What have you tried?

I appreciate you helping me out. I’m a noobster.

I haven’t actually tried anything yet. the installation is still on going on this laptop

but, okay so for example, how do i actually install Prime.

Am I understanding, that as soon as I am able to install the nvidia drivers, I just create that xorg.conf file and it should just work? should i have to sudo pacman -s something?

I dont know how to be specific with my hardware but this is the output of lspci | egrep 'VGA|3D|NVIDIA'

00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630]
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

I remember putting these lines under the lightdm seat when i got this working on manjaro xfce

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

i’m not sure where i should put these in gdm

In which case you’re trying to fix a problem that doesn’t exist.

Get EnOS installed, then worry about whether reverse PRIME is working.

i’m just preparing my bro. this isn’t the first time I installed EOS on this laptop. I just couldn’t grasp how get it to work the first time. I ended up using optimus manager. that logs me out whenever i switch. it was just janky.
are you implying that prime is preinstalled on EOS too?

Both the Nouveau and the NVIDIA drivers support render offloading. Depending on your hardware things may “just work” after installation, but that’s down to your hardware and what other software you install.

Don’t try to replicate what Manjaro did as EndeavourOS, being much closer to Arch, is not the same.

finished installation my bro and it’s definitely not offloading.

i ran the nvidia-installer-dkms script that was installed and it atleast gave me an nvidia-settings gui.

do you have any suggestions? :slight_smile:

nvtop reports only gnome shell is being ran off my gpu(usually discord is gonna be on here and some firefox tabs). this one game i play doesn’t run at all.

This means render offloading is working, though I’m surprised it would offload GNOME Shell and not anything else.

“Usually” isn’t helpful here as what was happening before is not necessarily the best result. Running standard desktop applications on the iGPU should be more power efficient and therefore what most people would want to happen by default.

I can’t guess what that game is or what the problem is. Sorry. :person_shrugging:

ive done everything relevant in the page. and nothing seems to be changing.

creating the /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf file

adding these xrandr lines to my xinitrc:

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

as outlined here:

and also created the /etc/X11/xorg.conf file.

the game i tried is called albion from steam
i installed another game called dont starve together, this one ran but nvtop does not say it is running off the gpu.

also remembered that there is a button at the bottom right of gdm login screen that has the options, switched from “Gnome” to “Gnome on Xorg”

what changed was that nvtop now reports that the only thing running off the gpu is Xorg as opposed to previously being gnome shell

still no luck. what am i missing?

Can you change the GPU in the BIOS, e.g. choose between “switchable” and “discrete”? If so, this is the better option.

This is also not “reverse PRIME” which is probably why you didn’t get it working before (or now).

You’re obviously free to do whatever you want with your system but looking for an actual solution would probably be more efficient.

Look at this section of the wiki:

You should also revert any other unrelated changes you have made so they don’t conflict.

I think the problem is that prime isn’t installed. I don’t have that prime-run command, how do i get that

if anybody is interested. I figured it out:

i freshly installed the iso again. this time with the none nvidia drivers boot menu option.
then i followed the steps from this yt:

but instead of doing the steps for lightdm on the nvidia prime page. I did the steps for gdm(make sure to click on that link that says, “make sure to use X as default backend” if you are using gnome)

everything is working now. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.