TF2 stuck in insecure mode


I am trying to use steam on EndeavourOS, but Team Fortress 2 is giving me an error message about being in insecure mode.

After some research, I have tried putting “-secure” and “-insecure” in the launch options, as well as clearing the download cache, which have all had no effect. I fear it may be a problem more with the os than steam?, which is why I’ve come here.

I’m on basically a fresh install, with essentially just steam and discord.

Thanks in advance for any suggestions/advice.

Are you using Proton? if so, try switching to Native.

I am using native. Proton crashes before getting to the titlescreen.

Try downloading lib32-gperftools from the aur

Then try setting this in the launch options: LD_PRELOAD="/usr/lib32/$LD_PRELOAD" %command%

1 Like

Nothing seems to have changed, still the same “you are in insecure mode”.

I’ve just installed TF2 on my system and I was able to join VAC servers with no issue. When launching the game, a pop up appeared, asking me what version I should play and I picked “Play Team Fortress 2”. Did you choose some other option?

If nothing works, perhaps try to verify the game’s files integrity. If this also doesn’t work, completely remove TF2(uninstall it from Steam and then remove the remaining files left by it) and re-install it.

Might be worth asking if you use the Flatpak version or the native one too.

I completely uninstalled and reinstalled tf2 and it works now, in windowed mode? when i put it on borderless or fullscreen it doesn’t launch and disables my second monitor, for some reason?? in my display settings, there’s also now a “None-1-1” monitor showing up, despite me only having two monitors plugged in.

TF2 runs better in windowed for me. I have these launch options:
-windowed -w 1920 -h 1080 Obviously you’d want to change it to whatever resolution you have.

X11 or Wayland?

X11, on the EndeavourOS xfce