Text does not appear in some apps

Hello everyone:

I am a Linux newbie. I installed EndeavourOS with Xfce desktop on an external SSD, to run the same system on different computers. However, when I run it on a particular old computer, some applications do not display the text correctly.

Examples of the problem:

Details of the installed EndeavourOS (Gemini):

  • Xfce version: 4.18
  • GTK version: 3.24.42
  • Kernel version: 6.9.6-arch1-1

Details of the old computer:

  • Brand/Model: PackardBell EasyNote MX410
  • Processor: Intel Core 2 Duo T7400 @ 2.16GHz
  • Chipset: Intel i945GM
  • RAM: 3Gb DDR2-667

Other slightly newer computers, such as a Toshiba Satellite L305 (Intel Core 2 Duo T6600 CPU, GM45 chipset and 4Gb DDR2-800) do not have the problem.

NOTE: I just installed EndeavorOS and have not made any changes to the default settings.

I would be grateful for any help that you can provide. Thank you!

I think there might be a problem with Qt theming, at least on the KDE Discover part (I don’t know if EOS Quickstart Installer is a Qt app or not, it’s a question towards EOS dev team).

Have you tried uniform theming for Qt and GTK apps? Install qt5-styleplugins and qt6gtk2 from AUR, then set QT_QPA_PLATFORMTHEME=gtk2 in your /etc/environment file (remember to edit the file as root - use sudo).

Thank you very much for your answer. I followed your instructions, but the result was this:

Text refuses to appear

Could you set dark GTK theme for reference? I’d like to see if the text would appear light on dark as it should.

I tried the 7 available themes, but the text still has “stage fright”

You said you’ve tried them all, but to show it better, you should show a screenshot with an actual dark theme arc-darker isn’t really a dark theme. Please select arc-dark and replace your current screenshot with that.

Also, based on @erne.d.98 suggestions and what I know about EndeavourOS, yes, the app is Qt-based — it’s one of the reasons why KDE is the default DE.

So, this means using a Gtk theme manager will not help with Qt apps, you’ll need a Qt theme manager instead, like qt6ct (recommended) and/or qt5ct. It would also be a good idea to install kvantum. If neither qt6ct nor kvantum find the same arc-dark or arc theme in Qt form, then you’d need to download those too.

step 1

Check Font Settings:

  • Open the Xfce Settings Manager.
  • Go to “Appearance” and then the “Fonts” tab.
  • Ensure that the fonts are correctly set and not corrupted.

step 2
Update System and Drivers

sudo pacman -Syu

step 3

Graphics Driver Issues:

  • Old computers might have issues with certain graphics drivers. Ensure that the correct driver is installed for your GPU.

For Intel graphics, you can try installing the xf86-video-intel driver:

sudo pacman -S xf86-video-intel

step4

Xfce Compositor Settings:

  • Sometimes, the compositor settings in Xfce can cause display issues. Disable the compositor to see if it resolves the problem.

  • Go to “Settings” → “Window Manager Tweaks” → “Compositor” and uncheck “Enable display compositing.”

step5
Check for Missing Fonts:

  • Ensure that all necessary fonts are installed on your system. You can install some common font packages using:

sudo pacman -S ttf-dejavu ttf-liberation noto-fonts

and if you could can you provide more screenshots like ddnn said

1 Like

1 Like

Have you tried using qt6ct/kvantum/qt5ct to change the Qt settings manually?

Step 1
Everything seems OK.

Step 2
…the system is already updated

Step 3
xf86-video-intel is updated – reinstalling

Step 4
“Enable display compositing” unckecked

Step 5
Fonts are updated and reinstalled

NOTE: Thank you so much, @zdislav. Your instructions are very precise, which helps me follow them.

I don’t use Kvantum yet. I already installed it, but I have to learn how to use it. Remember that I am a newbie.

I am just realising that you’re a newbie, actually. My fault. :sweat_smile:

kvantum is mostly straight-forward, so it won’t be too difficult.



  • Once you open it, click on “Change/Delete Theme”
  • Click the button to the right, it’s a drop-down menu with all your Qt themes
  • Select a theme
  • Click “Use this theme”

if ddnn solution doesnt work you could try Rebuild the font cache:

sudo fc-cache -fv

you could also Check for Log and Error Messages

sudo journalctl -p err -b

Look for any messages that could indicate issues with your graphics driver or other related components.

also what you could try is use default theme

For some reason, the changes are only shown in the Kvantum Manager window, but the other windows have no changes.
Will I have the environment file configured incorrectly? (Lower left corner of the screenshot).
Thank you all very much, but due to schedule reasons I will have to continue tomorrow.

Try this:

export QT_QPA_PLATFORMTHEME=qt6ct

OR

export QT_QPA_PLATFORMTHEME=qt5ct

Also, if you have the files .bashrc and/or .zshrc in your home directory, put one of these lines at the end. Could also be placed in .profile.

You may need to log out and log in to check if either variable works properly.

Hello and welcome,

Did you run the commands qt5ct or qt6ct in a terminal ? If yes, do the previews look good ? Is the style set to gtk2 ? Same for the fonts settings.

This may sound stupid but are you sure the font what is set in font config is actually installed?

Your problem looks like a missing or corrupt font, what happens when you choose a different font?

If you want Kvantum changes to be applied, you might need to set QT_QPA_PLATFORMTHEME in your environment file to kvantum. Or if you used qt5ct or qt6ct - their respective names.
Tbh I’m no master at this, I did what I suggested in my first reply and VLC (which is the only Qt app I use on my Xfce) is correctly themed:

obraz

Maybe try installing VLC to see the reference? If VLC is themed as specified in your environment file, it might be a problem with Discover as well. Can’t say much about eos-quickstart since I purged it out of my installation on day one :melting_face:.

By using qt5ct or qt6ct, they also load with the theme in use by Qt apps, so installing VLC (which may already be installed) to check won’t be necessary.

However, environment variables may indeed be the issue.


@TitoHL

sudo nano /etc/environment

Add/Change the line below.

QT_QPA_PLATFORMTHEME=qt6ct

This should fix it. Instead of qt6ct, you may also use qt5ct or kvantum.