Testing Plasma 6 (Beta) on Endeavour OS - is this approach any good?

After the last update Dolphin now behaves as expected: at every CTRL-T a new tab appears.

Case solved :slight_smile: .

edit typo.

edit edit: typo in “typo” :rofl:

Have tried to reproduce but can´t confirm, I’m afraid. The screen lights up as expected each time my laptop wakes up.

Could have to do with mine is an external monitor (not a laptop)…maybe someone else will be able to confirm/deny later. Or maybe on the Beta, it’ll go away lol

Testing Plasma 6/QT 6 pre-beta is becoming rather boring, to be frank - in a good way: on my set up no spectacular crashes, no explosions or fireworks, just some small nuisances and, as to be expected, some things still clearly lacking at the moment. And more than once daily updates - people at kde are evidently working hard.

I use Plasma 6 on a daily basis now and can simply get things done, like on my Plasma 5 setup.

Coming week I’ll be away from my laptop, so I won’t be reporting any new Plasma 6 shenanigans for that period.

I hope you’ll all keep rolling and testing in the mean time :blush:.

Haha, yes we need other people to bounce our findings off. Join us…it really isn’t that painful if you are the least bit ‘experimental’. :slight_smile:
Enjoy your time away…beta 1 will probably be available while you’re gone :slight_smile:

1 Like

Did you experience any crash when enabling floating panel while plasma panel is at the top position? This happens to me in wayland session.

My setup: Plasma 6 alpha + Wayland + Nvidia 545.29.06 driver.

1 Like

The “edit mode” is not stable on my end, crash from time to time with no apparent reason (team red).

First time I tried edit mode it indeed crashed and I couldn’t change the position of my panel. A couple of updates later edit mode did work, so I changed the position of my panel to my liking and never changed it again. So, I can’t say I have extensively tested the edit mode -should’ve done, I suppose, and will do as soon as I can.

I also try to set things and don’t touch them anymore. But from time to time i need to enter edit mode mostly because i reorder my task icon for them to be on the good side of my monitor (ultrawide) and pulling them to far to the right/left make a widget (that can’t be delete without entering in this mode). Would love a toggle to disable this behavior to be honest.

Turns out, my laptop came with me :joy:. So I’ll be testing some more this week.

I can confirm: edit mode is not stable. Just moved the panel to the left side, and changed the width - desktop froze and then crashed. Will try to get logs and see if this has already been reported over at bugs.kde.org.


Not sure yet what the right keywords are to look for bugs related to “edit mode” or crashes of the desktop/Plasma. Did see quite a number of bug reports though that seem to have the “edit mode” theme.

One example: https://bugs.kde.org/show_bug.cgi?id=471292

Too technical for me, but perhaps some of you can find out whether your crash may be related and then add some more relevant data?

Probably “plasmashell”.

I will do that this weekend :slight_smile:

Thank you! Will check logs.

Yup - seems to be right:

systemd-coredump[1639]: [🡕] Process 933 (plasmashell) of user 1000 dumped core.
                                                            Stack trace of thread 933:
                                                            #0  0x00007f350796257f _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt6Core.so.6 + 0x16257f)
                                                            #1  0x00007f3507fe9ad0 _ZN15QPlatformWindow20deliverUpdateRequestEv (libQt6Gui.so.6 + 0x1e9ad0)
                                                            #2  0x00007f35079a5077 _ZN7QObject5eventEP6QEvent (libQt6Core.so.6 + 0x1a5077)
                                                            #3  0x00007f350897318b _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent (libQt6Widgets.so.6 + 0x17318b)
                                                            #4  0x00007f35079626d8 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt6Core.so.6 + 0x1626d8)
                                                            #5  0x00007f3507962a5b _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt6Core.so.6 + 0x162a5b)
                                                            #6  0x00007f3507b99d24 n/a (libQt6Core.so.6 + 0x399d24)
                                                            #7  0x00007f3506583f69 n/a (libglib-2.0.so.0 + 0x59f69)
                                                            #8  0x00007f35065e2327 n/a (libglib-2.0.so.0 + 0xb8327)
                                                            #9  0x00007f3506582162 g_main_context_iteration (libglib-2.0.so.0 + 0x58162)
                                                            #10 0x00007f3507b97934 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt6Core.so.6 + 0x397934)
                                                            #11 0x00007f350796cc5e _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt6Core.so.6 + 0x16cc5e)
                                                            #12 0x00007f3507965178 _ZN16QCoreApplication4execEv (libQt6Core.so.6 + 0x165178)
                                                            #13 0x00005630803fe22c n/a (plasmashell + 0x2f22c)
                                                            #14 0x00007f3507245cd0 n/a (libc.so.6 + 0x27cd0)
                                                            #15 0x00007f3507245d8a __libc_start_main (libc.so.6 + 0x27d8a)
                                                            #16 0x00005630803fe9e5 n/a (plasmashell + 0x2f9e5)

And a lot more info like this.

1 Like

From what I gather from the other bug reports at bugs.kde.org about edit mode leading to plasmashell crashing I decided to report a separate bug - as the other bugs seemed to be about different scenario’s.

Anyone more knowledgeable than me: what’s the best way to isolate the pertaining logs?

To get the lines containing ‘plasmashell’ from the logs, I did:

journalctl --user --grep='plasmashell' > error.txt

That resulted in too many lines many of which did not seem related.

As the lines that did seem relevant all started with ‘#’, I did:

cat error.txt | grep "#" > plasmashell.txt

which resulted in what I think were the relevant lines.

I’m sure there’s a better way.
Anyone got some pointers?

I did read articles like [1] but that does not show me how to isolate the info of one specific error/stack trace, which would be the ideal solution, I think.

[1] https://docs.rackspace.com/docs/how-to-use-journalctl-to-view-and-manipulate-systemd-logs

update, i fixed this issue by adding nvidia_drm.modeset=1

1 Like

only thing i didnt like was cairo-dock, i am still trying to make it work better, could not launch it but i could with this package
and i coundt enable opengl support so it wasnt running so smooth

I have a floating panel at bottom and it seems stable. Also Wayland (not Nvidia).
Btw, unless it changed again Cairo is on (or off) life support isn’t it ?