Testing Plasma 6 (Beta) on Endeavour OS - is this approach any good?

Testing has to be before non-testing. kde-unstable should be before other testing.

Most widgets probably need an update. Nothing big, but they wont run out of the box. The plasma widgets will be updated with the plasma release. For 3rd party widgets keep an eye on https://store.kde.org/browse?cat=705

I assume plasma 5 widgets will not update automatically but need a reinstall of the plasma 6 version. But I haven’t looked into that yet. I’m waiting for the next beta to be more stable to update my own store widget.

1 Like

Since some LTS distro will still provide plasma 5.27, you most likely right.

1 Like

Right - thanks! Will configure pacman.conf accordingly.

Edited my pacman.conf:

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Running yay now results in:

:: Synchronizing package databases...
 kde-unstable is up to date
 core-testing                                                                                      1236.0   B  5.49 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 extra-testing is up to date
 endeavouros is up to date
 core is up to date
 extra is up to date
 multilib is up to date
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)
 -> error refreshing databases - exit status 1

I found an article [1] that suggests how to resolve this error, but I 'm unsure about the procedure (which is new to me). Any suggestions, ideas?

[1] https://vadosware.io/post/fixing-gpgme-error-on-arch/

I’m not familiar with that one. Did you try a sudo pacman -Suyy?

Thanks for the suggestion. I tried. Same result though.

error: GPGME error: No data
:: Synchronizing package databases...
 kde-unstable                                                                                       113.2 KiB   419 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 core-testing                                                                                         8.4 KiB  36.7 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 extra-testing                                                                                       76.2 KiB   296 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 endeavouros                                                                                         26.7 KiB  40.7 KiB/s 00:01 [-----------------------------------------------------------------------------] 100%
 core                                                                                               132.8 KiB   437 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 extra                                                                                                8.3 MiB  5.59 MiB/s 00:01 [-----------------------------------------------------------------------------] 100%
 multilib                                                                                           141.2 KiB  94.6 KiB/s 00:01 [-----------------------------------------------------------------------------] 100%
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

Will try to find some more info about this error.

Interesting. Again, not familiar with that error. But I would try to update the mirror list - I don’t have it available at the moment, but afair the EndeavourOS startup app offers that option - and give the update another shot afterwards.

The pacman.conf looks fine as far as I can tell.

I just did that.

Then tried to update without the testing-core and testing-extra:

: Synchronizing package databases...
 kde-unstable                                                                                       127.8 KiB   107 KiB/s 00:01 [-----------------------------------------------------------------------------] 100%
 endeavouros                                                                                         26.7 KiB   134 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 core                                                                                               132.8 KiB   109 KiB/s 00:01 [-----------------------------------------------------------------------------] 100%
 extra                                                                                                8.3 MiB  2.48 MiB/s 00:03 [-----------------------------------------------------------------------------] 100%
 multilib                                                                                           141.4 KiB   114 KiB/s 00:01 [-----------------------------------------------------------------------------] 100%
:: Starting full system upgrade...
:: Replace appstream-qt with extra/appstream-qt5? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing appstream-qt breaks dependency 'appstream-qt' required by plasma-workspace

And then with (just, you know, to be thorough):

error: GPGME error: No data
:: Synchronizing package databases...
 kde-unstable                                                                                       127.8 KiB   441 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 core-testing                                                                                         8.4 KiB  48.5 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 extra-testing                                                                                       76.2 KiB   321 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 endeavouros                                                                                         26.7 KiB   136 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 core                                                                                               132.8 KiB   503 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
 extra                                                                                                8.3 MiB  5.57 MiB/s 00:01 [-----------------------------------------------------------------------------] 100%
 multilib                                                                                           141.4 KiB   397 KiB/s 00:00 [-----------------------------------------------------------------------------] 100%
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

OK, kde-unstable is pulling plasma-workspace (plasma 6) which requires appstream-qt, and you probably answered the replacement with Yes. So that aborts because of the unmet dependency.

Of course that doesn’t help with *-testing in, which you still probably want, but - maybe - you get away without *-testing since appstream-qt migrated from testing to stable now.

Don’t know what is causing the error: GPGME error: No data … Never encountered that one myself. Maybe clearing out the package cache with sudo pacman -Scc (note that the OS has to redownload every package afterwards)?

Thanks so much for your help. :pray:t2:

I tried

  • commenting out *-testing repos and then update: result: the same dependency error.
  • commenting out kde-unstable as well: result: the same dependency error

Then I did some more research on [1] and it seemed legit. So I did that procedure.
That did indeed resolved the

error: GPGME error: No data

I’m now stuck at “just” the dependency error. I would rate that as progress ;-).

Could it be that this dependency error needs to be reported over at bugs.kde.org?

(I think I saw that on my Plasma 5 setup the update from




went without a problem today.)

[1] https://vadosware.io/post/fixing-gpgme-error-on-arch/

Did not try that as I had done the procedure before I read your suggestion.

My bad. Should have searched on this forum first of course:

The Arch packagers moved appstream to -qt5 for the current plasma 5 version and appstream-qt for what is comming next.

Since that is an Arch specific matter I wouldn’t file on bugs.kde.org. A more appropriate place would be https://bugs.archlinux.org/ but I’m not sure about their policy accepting bugs reports at this moment since everything is still pretty much a early in-progress.

Personally I would say: In this early stage do quick test in a VM too, so you have a second data point and make sure that it isn’t just that particular distribution/repository/installation issue only. As time goes on and we are rolling into the betas filing at bugs.kde.org becomes more important, since it wont be a packaging issue anymore.


Very sound advice.

Will ponder whilst cooking some healthy food.

Now I’m hungry. :wink:

my experience on those LTS distros: The widgets won’t self-update to incompatible versions and when you try to install them later on you won’t find many that are still compatible with the old KDE version. (Has been the case for years now with KDE 4 which is still used on CentOS 7 - widgets that were installed many years back still work, widgets from the CentOS 7 repos also still work, anything I want to install for the at least 5 years simply won’t install as no compatible version is around)

so I would think that once updated, those widgets will update themselves to the Plasma 6 compatible one without reinstalling (but one might need to trigger the update manually)

1 Like

Did some sleuthing for:

Seems I may have found a solution.

First I ran yay to update packages that were waiting to be updated, ignoring appstream-qt.

Then from this source:


I ran:

sudo pacman -S appstream-qt && pacman -Suy

That gave no error.

Have no time to do some sanity checks at the moment. Will do that later.

Any idea about ksplashqml? I have a 30 second warning on startup that it failed to run. While I can’t say I really care…I prefer to avoid 30 seconds at startup when I can’t do anything :slight_smile:

I have no such delay or warning. Will have a look later today what is showing up in logs about ksplashqml.

Had a look at the logs with:

journalctl --grep='ksplashqml'

I do see:

`kernel: ksplashqml[764]: segfault at 8 ip 00007fc6113b389e sp 00007ffd81beb9b0 error 4 in libQt6Core.so.6.6.0[7fc6112b1000+358000] likely on CPU 7 (core 3, socket 0)

systemd-coredump[838]: [🡕] Process 764 (ksplashqml) of user 1000 dumped core.`

several times (on different CPU’s) on november 11th, but after that this message does not show up anymore.

I take it, your Plasma 6/QT6 up to date?