Terrible font rendering for Gmails in Evolution and Geary

Hi Everyone, some of the emails on my gmail account has terrible font rendering issue. I’ve searched old threads but wasn’t sure if those solutions apply to my issue.

I have installed various font packs (Microsoft, Mac, Noto, Google etc…) but still facing the same issue.

It looks like Sans Sarif fonts or Calibri fonts aren’t displaying correctly in the mail apps (Evolution, Geary, and Thunderbird). However, when I open the same email in the Chromium app, I can read the emails just fine. No rendering issue.

I am not sure what the issue is.

Geary App where fonts are terrible:
font issue

Chromium has no issues
Chromium fonts

1 Like

In gnome or in kde, you can change the system font to multiple options. Maybe one of them is that horrible font and you change to a good one it will look better. The chromium browser is using the default on your system probably.

I just have the default Gnome fonts. I tried changing to others but the email fonts don’t change.

I had gnome tweaks and used roboto font in everything when i used gnome and i didn’t had any problem with fonts on geary

Obviously the font in use :smile:
Browsers use different fonts, depending on their default (browser) font and on the web page browsing.
I suggest you check which font is used in Chrome and try to use it (or a similar) in your system app in question (depends on toolkit used, GTK, QT, etc).
Either default Chrome font, or the one in Gmail web page (using dev tools).

Thanks. Will take a look.

Is there a way to specify custom font just for these email apps (Evolution and Geary) ?

I don’t remember or know exactly. If they have a font in-app setting try it. Else, according to their toolkit and user session, use respective configuration (Gnome settings/tweaks, kvantum, qt5ct, lxappearance, or other).

Never used Geary, but in Evolution : you can change the fonts in preferences. I use Open Sans regular and they appear fine on a 1366x768 laptop screen.
Ask about custom fonts here evolution-list@gnome.org


1 Like

I suggest you to set your custom fonts manually in ~/.config/fontconfig/fonts.conf. Here is what mine looks like https://0x0.st/oP1h.xml. This should eliminate errors like this. After making your changes reboot or run fc-cache to rebuild fontconfig’s configuration and relaunch geary.


actually, the fix is to simply zoom in when opening the emails in a new tab.

There is some weird issue with HTML format where the default size is too small causing weird rendering issue.

I changed the minimum font size to 18 and it’s much better. :slight_smile:


Thanks everyone for your help and suggestions.


Hello. That didn’t help me unfortunately. Rendering issue is just because font size is too small in HTML format from what I gathered.

This is due to embedded bitmap in TTF fonts (especially in Calibri) that look bad at small sizes.
Fix is to disable using embedded bitmaps:

Thank you. This worked actually. I reverted my settings to the default (i.e minimum font size to be 0 in Evalution app) and added the following and it worked.


<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "urn:fontconfig:fonts.dtd">
  <match target="font">
    <edit name="embeddedbitmap" mode="assign">

One question: I have the win-vista font package installed which has the Calibri fonts then why do I need to disable embedded bitmap TTF fonts?

Should I install some other package to get the Calibri fonts? What font package you recommend to get these fonts ?

AFAIK it just disables the embedded bitmaps in the TTF font and uses the proper vector rendering so you’re still using the actual font.

I just copied fonts from a Windows 10 installation to /usr/share/fonts rather than use a package

I don’t have an ISO to extract… I will see if I can use one from my parents laptop.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.