Terminal changing from full screen to floating without any user input


I’ve tried searching for a solution to this issue without finding one. The following is how I reproduce this issue:

This is a completely new install with EndeavourOS Artemis Nova 22.9. I open a terminal & it works as expected. It’s only when I run htop will it run full screen for a second and then automatically switches to a floating window without any input from me. I haven’t found any other apps yet that do this. I tried looking thru the waybar and sway configs and found $term-float in my sway config. I tried changing that to $term, but it did not change the behaviour.

Does anyone have any ideas?

Which DE/WM? Ignore me :smiley:

44:for_window [title="htop"] floating enable, resize set width 50 ppt height 70 ppt

That is the problem!


Thank you very much! That solved the issue. I had not see that behaviour on older versions of EndeavourOS with sway before, so that must be new.

1 Like

no. it be there long times ( basically from start ) at lease you have your fix now . hope you enjoy sway on Endeavouros .


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.