Systemd service removed upon reboot

I’m having trouble making Mullvad autostart. It has never been problematic before, but after doing a new OS installation something seems to remove the systemd service on reboot. My current steps have been:

  1. Install mullvad-vpn with paru (stable or beta make no difference, neither do the bin versions).
    2a. Enable autostart in the application - this has been sufficient before, but does not work now (I assume it enables the systemd service as it should, but that it is then removed somehow).
    2b. Manually enable the systemd daemon with sudo systemctl enable mullvad-daemon.service as per the ArchWiki.

If I add the --now flag, I can see the daemon running, but as with both a and b, after a reboot running sudo systemctl status mullvad-daemon.service returns Unit mullvad-daemon.service could not be found.

Any ideas?

You should post your system info, to help us speculate on your issue.

Are you sure you are not booting to a btrfs snapshot, or on a Live ISO?

inxi -Faz
pacman -Qs mulvad

Too late now, didn’t have the patience to keep troubleshooting it so I took a different path to solve it.

I’m quite sure.

Never leave a problem solved without telling what you did. Otherwise people that have the same problem have no leads to go on.


Yes, except, as I said, I took a different path. I did not solve it. There was no solution. I installed distro without systemd on it.

I’m pretty sure that systemd wasn’t the problem here.

I’m quite certain I never claimed it was.

That is always a good thing to know if you are searching for help on the internet. If someone would’ve seen this thread, he might have thought, “well, what path did he take?”. In the end you made a clean install, which solved the issue.

I don’t think it is particularly helpful. The cause was not identified and the problem was not solved. Proposing someone ditch EnOS as a solution to a problem seems - to me - counterproductive to the purpose of this forum. Nevertheless, it is there now.

1 Like