Systemd-boot: Is there is way to increase the font size?

systemd-boot looks ridiculous. Black screen and little white text in the middle! Why middle of the screen?! Why not just on the top like GRUB?

Ok, rant over. Can I just increase the font size? Pretty please?

In /efi/loader/loader.conf try setting console-mode 0


Press “r” key in bootloader

1 Like

What is the benefit of doing it that way as opposed to using bootctl in terminal?

The hotkeys and bootctl set EFI firmware variables. IMO, it is a lot cleaner and lower risk to use the config file.

That being said, I am not even sure you can change that particular setting via bootctl

Thank you it worked! The text is now bigger.

I guess it decreased the resolution. Hopefully systemd-boot can be more customized in the future.

1 Like

After coming from varying designs of Grub, Plymouth and then rEFInd, systemd-boot feels like something from the 1980’s. I get that it’s “just a bootloader” but even UEFI boot options look better. From a visually impaired perspective, thankfully I only run Linux, otherwise I wouldn’t be able to see what the heck it’s saying, the text is tiny.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.