Systemd-boot fails to boot EndeavourOs after every system update

Hi there,

I’ve been facing this issue since December 10, 2023. Every time I reboot after a system update, the boot manager fails to work, leaving me with a black screen that lasts forever. When this first occured in December, I panicked because I had a lot of work to do and needed my computer to just work :sweat_smile: . So I reverted to a physical copy of EnOs and continued working without updating until mid-January when I began investigating the problem.

Initially, I examined Pacman logs and I didn’t notice any errors occured during the system upgrade. You can find the log here.

During the December 10 upgrade, the major updates included:

  1. systemd-boot
  2. linux
  3. linux-headers

Since I was using the Arch stable kernel, I suspected a kernel issue. Therefore I switched from Arch to LTS. Unfortunately, after rebooting, I encountered the same black screen. To change kernels, I used EnOs AKM and after installing linux-lts and linux-headers-lts I executed the command reinstall-kernels.

Systemd-boot was my last resort. I extensively researched wikis and foums, including this one. Yesterday I “solved” the issue by chrooting into my disk using the EnOs live image and reinstalling systemd-boot using bootctl install . For reference I followed these two guides: EndeavourOs Wiki on arch-chroot and ArchWiki on systemd-boot.

However, today after updating the system and rebooting, I still ecountered the black screen instead of the bootloader. So, I chrooted into the system again and I’m now writing this thread with EnOs.

How can I permanently solve this issue? While chrooting after every update isn’t a huge problem, I would prefer to symply reboot :wink:

Here are some diagnostic outputs that may be useful:

  1. pacman -Q | grep -i -E "xf86|dracut|mkinitcpio|mesa"
dracut 059-5
kernel-install-for-dracut 1.10.1-1
libva-mesa-driver 1:24.0.2-1
libxxf86vm 1.1.5-1
mesa 1:24.0.2-1
mesa-demos 9.0.0-3
mesa-utils 9.0.0-3
xf86-input-libinput 1.4.0-1
xf86-input-wacom 1.2.0-1
xf86-video-amdgpu 23.0.0-1
xf86-video-ati 1:22.0.0-1
xf86-video-intel 1:2.99.917+923+gb74b67f0-1
  1. inxi -Fxxxz
  Kernel: 6.6.20-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 7 dm:
    1: LightDM v: 1.32.0 2: SDDM note: stopped Distro: EndeavourOS
    base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X399-A v: Rev 1.xx
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 1206 date: 07/15/2021
  Info: 6-core model: AMD Ryzen Threadripper 2970WX bits: 64 type: MT MCP MCM
    smt: enabled arch: Zen+ rev: 2 cache: L1: 2.2 MiB L2: 12 MiB L3: 64 MiB
  Speed (MHz): avg: 2188 high: 3000 min/max: 2200/3000 boost: enabled cores:
    1: 1946 2: 2200 3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200
    10: 2200 11: 1813 12: 2200 13: 2200 14: 2200 15: 2200 16: 2200 17: 2200
    18: 2200 19: 2200 20: 3000 21: 2200 22: 2200 23: 1986 24: 2200 25: 2200
    26: 2200 27: 2200 28: 2200 29: 2200 30: 2200 31: 2200 32: 2200 33: 2200
    34: 1713 35: 2200 36: 2200 37: 2200 38: 2200 39: 2200 40: 2200 41: 2200
    42: 2200 43: 2200 44: 2200 45: 2200 46: 2200 47: 2200 48: 2200
    bogomips: 287535
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Vega 20 [Radeon VII] driver: amdgpu v: kernel arch: GCN-5
    pcie: speed: 8 GT/s lanes: 16 ports: active: DP-1,DP-2,HDMI-A-1 empty: DP-3
    bus-ID: 43:00.0 chip-ID: 1002:66af class-ID: 0300
  Display: x11 server: X.Org v: 21.1.11 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 7680x3240 s-dpi: 96 s-size: 2030x856mm (79.92x33.70")
    s-diag: 2203mm (86.74")
  Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,bottom-l
    model: LG (GoldStar) HDR 4K serial: <filter> res: 3840x2160 hz: 60 dpi: 163
    size: 600x340mm (23.62x13.39") diag: 690mm (27.2") modes: max: 3840x2160
    min: 640x480
  Monitor-2: DP-2 mapped: DisplayPort-1 pos: top-left
    model: LG (GoldStar) 2D FHD TV serial: <filter> res: 1920x1080 hz: 60
    dpi: 96 size: 509x286mm (20.04x11.26") diag: 584mm (23") modes:
    max: 1920x1080 min: 720x400
  Monitor-3: HDMI-A-1 mapped: HDMI-A-0 pos: bottom-r model: ASUS PA329CV
    serial: <filter> res: 3840x2160 hz: 60 dpi: 138
    size: 708x399mm (27.87x15.71") diag: 813mm (32") modes: max: 3840x2160
    min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon VII (radeonsi vega20
    LLVM 16.0.6 DRM 3.54 6.6.20-1-lts) device-ID: 1002:66af
  API: Vulkan Message: No Vulkan data available.
  Device-1: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 0b:00.3 chip-ID: 1022:1457
    class-ID: 0403
  Device-2: AMD Vega 20 HDMI Audio [Radeon VII] driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 43:00.1 chip-ID: 1002:ab20
    class-ID: 0403
  Device-3: Focusrite-Novation Scarlett Solo (3rd Gen.)
    driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    bus-ID: 7-2.1:5 chip-ID: 1235:8211 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.6.20-1-lts status: kernel-api
  Server-1: sndiod v: N/A status: off
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 05:00.0 chip-ID: 8086:1539
    class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Edimax EW-7711UTn nLite Wireless Adapter [Ralink RT3070]
    driver: rt2800usb type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 7-1:2
    chip-ID: 7392:7711 class-ID: 0000 serial: <filter>
  IF: wlan0 state: down mac: <filter>
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-12:3 chip-ID: 0b05:17cb
    class-ID: fe01 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 class-ID: 6c0104
  Local Storage: total: 30.02 TiB used: 20.09 TiB (66.9%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT2000P3SSD8 size: 1.82 TiB
    speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A
    temp: 32.9 C
  ID-2: /dev/sda vendor: SanDisk model: SDSSDH31000G size: 931.51 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 70RL scheme: GPT
  ID-3: /dev/sdb vendor: Toshiba model: HDWD240 size: 3.64 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter> fw-rev: 0A scheme: GPT
  ID-4: /dev/sdc vendor: Toshiba model: HDWD130 size: 2.73 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: ACF0
    scheme: GPT
  ID-5: /dev/sdd vendor: Toshiba model: HDWD240 size: 3.64 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter> fw-rev: 0A scheme: GPT
  ID-6: /dev/sde vendor: Seagate model: ST3000DM008-2DM166 size: 2.73 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: CC26
    scheme: GPT
  ID-7: /dev/sdf vendor: Seagate model: ST8000DM0004-1ZC11G size: 7.28 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: DN01
    scheme: GPT
  ID-8: /dev/sdg vendor: SanDisk model: ST8000DM004-2CX188 size: 7.28 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 5425 serial: <filter> fw-rev: 0001
    scheme: GPT
  ID-1: / size: 846.92 GiB used: 156.29 GiB (18.5%) fs: ext4 dev: /dev/sda2
  ID-1: swap-1 type: partition size: 69.01 GiB used: 16.2 MiB (0.0%)
    priority: -2 dev: /dev/sda3
  System Temperatures: cpu: 31.0 C mobo: 24.0 C gpu: amdgpu temp: 35.0 C
    mem: 30.0 C
  Fan Speeds (rpm): cpu: 0 case-1: 928 case-2: 0 case-3: 924 fan-1: 968
    gpu: amdgpu fan: 867
  Power: 12v: 11.90 5v: N/A 3.3v: N/A vbat: 3.03 gpu: amdgpu watts: 28.00
  Memory: total: 64 GiB available: 62.73 GiB used: 7.01 GiB (11.2%)
  Processes: 815 Power: uptime: 28m states: freeze,mem,disk suspend: deep
    wakeups: 0 hibernate: platform Init: systemd v: 255 default: graphical
  Packages: 1618 pm: pacman pkgs: 1601 pm: flatpak pkgs: 9 pm: snap pkgs: 8
    Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 running-in: konsole
    inxi: 3.3.33
  1. cat /etc/kernel/cmdline
    nvme_load=YES rw root=UUID=b416fd65-071e-4429-8a7f-381ea411d664 resume=UUID=aff818ec-9037-45b0-9126-fa412baf3429
  2. bootctl status
/efi/loader/loader.conf:5: Unknown line 'reboot-for-bitlocker', ignoring.
      Firmware: UEFI 2.60 (American Megatrends 5.13)
 Firmware Arch: x64
   Secure Boot: disabled (setup)
  TPM2 Support: firmware only, driver unavailable
  Measured UKI: no
  Boot into FW: supported

Current Boot Loader:
      Product: systemd-boot 255.4-1-arch
     Features: ✓ Boot counting
               ✓ Menu timeout control
               ✓ One-shot menu timeout control
               ✓ Default entry control
               ✓ One-shot entry control
               ✓ Support for XBOOTLDR partition
               ✓ Support for passing random seed to OS
               ✓ Load drop-in drivers
               ✓ Support Type #1 sort-key field
               ✓ Support @saved pseudo-entry
               ✓ Support Type #1 devicetree field
               ✓ Enroll SecureBoot keys
               ✓ Retain SHIM protocols
               ✓ Menu can be disabled
               ✓ Boot loader sets ESP information
          ESP: /dev/disk/by-partuuid/fb8459a9-b31d-ce4b-b428-206744c3b5cd

Random Seed:
 System Token: set
       Exists: yes

Available Boot Loaders on ESP:
          ESP: /efi (/dev/disk/by-partuuid/fb8459a9-b31d-ce4b-b428-206744c3b5cd)
         File: ├─/EFI/systemd/systemd-bootx64.efi (systemd-boot 255.4-1-arch)
               └─/EFI/BOOT/BOOTX64.EFI (systemd-boot 255.4-1-arch)

Boot Loaders Listed in EFI Variables:
        Title: Linux Boot Manager
           ID: 0x0000
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/fb8459a9-b31d-ce4b-b428-206744c3b5cd

        Title: UEFI OS
           ID: 0x0003
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/fb8459a9-b31d-ce4b-b428-206744c3b5cd
         File: └─/EFI/BOOT/BOOTX64.EFI

Boot Loader Entries:
        $BOOT: /efi (/dev/disk/by-partuuid/fb8459a9-b31d-ce4b-b428-206744c3b5cd)
        token: endeavouros

Default Boot Loader Entry:
         type: Boot Loader Specification Type #1 (.conf)
        title: EndeavourOS (6.6.20-1-lts)
           id: 7fbcae0cab2140a5901d6d0380e19870-6.6.20-1-lts.conf
       source: /efi//loader/entries/7fbcae0cab2140a5901d6d0380e19870-6.6.20-1-lts.conf
     sort-key: endeavouros-6.6.20-1-lts
      version: 6.6.20-1-lts
   machine-id: 7fbcae0cab2140a5901d6d0380e19870
        linux: /efi//7fbcae0cab2140a5901d6d0380e19870/6.6.20-1-lts/linux
       initrd: /efi//7fbcae0cab2140a5901d6d0380e19870/6.6.20-1-lts/initrd
      options: nvme_load=YES rw root=UUID=b416fd65-071e-4429-8a7f-381ea411d664 resume=UUID=aff818ec-9037-45b0-9126-fa412baf3
  1. content of /efi/loader/loader.conf
default 7fbcae0cab2140a5901d6d0380e19870*lts.conf
timeout 5
console-mode auto
reboot-for-bitlocker 1
  1. EDIT: this is the output of bootctl install when chrooting
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/efi/EFI/systemd/systemd-bootx64.efi".
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/efi/EFI/BOOT/BOOTX64.EFI".
:warning: Mount point '/efi' which backs the random seed file is world accesible, which is a security hole! :warning:
:warning: Random seed file '/efi/loader/random-seed' is world accessible, which is a securitiy hole! :warning: 
Random seed file /efi/loader/random-seed successfully refreshed (32 bytes).
Created EFI boot entry "Linux Boot Manager".

Lastly, here are the details of my system from neofetch :
OS: EndeavourOS Linux x86_64
Kernel: 6.6.20-1-lts
Shell: zsh 5.9
DE: Plasma 5.27.10
WM: KWin

Has anyone experienced this problem before? Do you have any advice on how to solve it?

Thank you in advance,

P.S.: Please forgive my poor English!

EDIT: I don’t multiboot, I only have EndeavourOs installed.

Hi, do you have systemd-boot set to update boot manager once new version comes?

1 Like

Hi! Thank you for your kind reply! I’ve never set up automatic updates before. Do you think I should give it a try by adding a pacman hook as mentioned in the ArchWiki?

Someone else had a similar issue not too long ago and it turned out to be a BIOS issue.

Are you running the latest BIOS version for your hardware?

1 Like

No, the kernel-install-for-dracut already includes these hooks.

You can see in your pacman hooks where this is happening.

1 Like

Hi @dalto ! Thank you for your reply! I’m running latest BIOS version. Last year, I updated the BIOS to the latest version, and since then, I’ve been booting into EndeavourOS without any issues.

I will check the pacman hooks! EDIT: the hooks are included.

The hooks are definitely already there.

Adding hooks here will be counterproductive.

1 Like

I’ve just discovered that ASUS released a new BIOS version yesterday, marking the first update in three years. Would you recommend that I attempt to update the BIOS before trying any other troubleshooting steps?

Just to confirm, is CSM support in your BIOS enabled or disabled?

1 Like

Hi, thank you for your kind reply!
This is the status of CSM in my BIOS. Should I adjust any parameters?

1 Like

I had somewhere nearly the same issue. Then i disabled CSM and everthing bootet up as it should.

I had hundreds of possibilities that I thought could be mistakes. From not updating the BIOS to a new BIOS battery. In the end it was the enabled CSM support. Try it.


It’s best to have CSM turned disabled. I don’t know if the settings below change after booting?
(legacy only)

Maybe they are default settings when CSM is enabled. I usually set to boot UEFI only on my hardware unless i have a need to boot something in legacy mode because the system is UEFI not the old Bios standard.


had the same problem, disabling CSM solved the problem for me :slight_smile:


Disabled CSM, updated EndeavourOS (requiring a reboot) and it worked!!!

You all are seriously genius!! I would have never thought of it (I didn’t even know about the existence of CSM :sweat_smile:)!

Thanks again to this amazing community!


Glad you got it worked :enos:!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.