System won't shutdown

Hey guys, recently I have been facing a hang on shutdown. I have to power my machine off by pressing the power button for a couple of seconds. As I have no real idea how to solve this, I’d be happy if someone could point me towards having my system shutdown properly.

start here and learn about logs and which can do what and how to display relevant information to us.

giving us basic information like hardware/software will make is easier to help diagnose.

1 Like

What @thefrog said. But also have you tried out using a different kernel? I had this issue a while ago and the solution for me was to switch to the LTS kernel at the time.

Booted into the LTS kernel. The system shut down normally. Switched to non-LTS, and the system shuts down normally too for the first time in almost a week.
Will observe this and get back here when the hang on shutdown reappears.

1 Like

Yer mine has now worked with all kernels for a while but I generally just stick with the LTS as I have never had this issue with it.

There was an issue with Bluetooth devices holding up the shutdown/restart. I think they patched it in the new kernel. Just try using the newest kernel would solve this.