System won't shut down

Since I reinstalled EOS last month my intel i7 based laptop w/ nvidia won’t shut down, it just stays on the black console screen with the blinking cursor and I have to press the “magic sysrq” key combination to force a shutdown. My dmesg doesn’t show anything unusual. Apart from that everything else just works. Perhaps something to do with the latest kernels or other packages? What should I check to try to figure out the reason?

1 Like

Have you tried systemctl poweroff in a terminal to see if it shows any error messages?

1 Like

Are you using GDM and Gnome desktop? I do and I ran into this bug …
Gnome/systemd 2 min shutdown delay

… of course if you are using a different desktop, this won’t apply.

You will probably want to read (or at least scan through) the entire bug report from the top to see if it applies to you. I could see some messages in the journal from the prior session using
sudo journalctl -r -b -1
which showed overlapping user session start and shutdown at the same time causing a two minute timeout for the attempted start before shutdown would complete.

4 Likes

Yes, I’m using Gnome and gdm. Applying the fix you linked in your comment appears to have solved the issue. Thanks!