System won’t boot after update: failed to mount /boot

Context: I ran the update command but system won’t boot after reboot. The thing that got updated was the linux kernel. The first error I saw after the reboot was “Failed to mount /boot. cannot read signature of vfat” or something like that. I then tried to use fdisk to change the type to EFI again. the first error I saw was gone but it still won’t boot. The error I see now is on the image I provided.

Disclaimer: I’m not using EOS but the vanilla arch instead. I went to this forum since the arch forum needs some stupid verification from the output of the terminal for user registration.

hmmm I point you in direction

have read here
" "

" "

you can also research " sign up to Arch forum "

EDit > Arch is fun! isn’t it :blush: :innocent:


As pointed out by @Shjim you would most probably need to chroot into your system from your live usb.

Once in chroot, you could run the update command once again. Perhaps also reinstall your kernels etc.

If you need more specific instructions, boot up your live usb and post the output of

sudo parted -l

1 Like

after trying to mount my boot partition to /boot/efi it says wrong fs type

nvm i got it to mount after " mkfs.fat -F 32 /dev/efi_system_partition". got the command from arch wiki

do I need to run mkswap and swapon again too?

I ran the commands again since there was no swap detected when i ran “swapon -s”

In order to solve a problem, you have created a couple of new ones.

By formatting your ESP, you have practically wiped your bootloader and changed the UUID of the partition. 2 additional issues needing to be addressed.

Please stop running commands that you don’t know the implications of!

And in order for us to be able to help you, provide us with the information requested: