System upgrade conflict [svt-av1] [lib32-svt-av1]

I was trying to upgrade my system and got a dependency conflict error

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing svt-av1 (1.7.0-1) breaks dependency 'svt-av1=1.6.0' required by lib32-svt-av1

How do I solve this?

See if this post can be of any help:

Thank you for your reply.
I had already found this post. But it does not help. He did not share how he solved the issue (He himself doesn’t know I think)

What does it actually mean?
It’s no longer on the AUR?

If it has been installed on your system before from the official repos, it seems it is no longer available there. It is currently in the AUR.

What does the following command show?

pactree -r lib32-svt-av1

>>> pactree -r lib32-svt-av1

Does this mean I can just remove it? I’m scared to do it though. Don’t know if its being used or not.

Yes. Nothing else in your system is dependent on this package. Otherwise you would have had a list of those packages.

You could do:

sudo pacman -R lib32-svt-av1 && sudo pacman -Syu

to first remove that package and then update the packages you have installed originating from the official repos.


It worked!
Thank you

1 Like

You are welcome!
Glad you got it sorted out!

And welcome to EnOS’ community @rd_626!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.