System update stuck on older version

I know this is going to sound strange but my system is stuck on linux 6.8.5 and I am unable to update it to anything newer. It is a similar story for other packages like firefox 124.0.2-1 and flatpak 1:1.15.7-1.

Running sudo pacman -Syyu or sudo pacman -Syu yields the following result:

:: Synchronizing package databases…
endeavouros is up to date
core is up to date
extra is up to date
multilib is up to date
:: Starting full system upgrade…
there is nothing to do

I have cleared the pacman cache with the following command to no avail: sudo pacman -Scc

I am at a loss for what to do next, my system is functioning fine and as expected for the current version that everything is on. I have other hardware with EndevourOS on it and it has the latest of all the above.

Any advice would be appreciated let me know if there are any logs that I should be looking at.


Hi and welcome, have you tried to update your arch mirrors from the welcome screen yet?

Thank you for the quick response.

I’m not seeing a option for that, is there a command I could run that would accomplish the same thing?

what happens if you run this command?


You have to change to “Assistant”. There you can find “update arch mirrors”.


ran successfully, doesn’t look like it changed anything.

You’d need to install package rate-mirrors or reflector or both.
Then you’ll see them in Welcome.

1 Like

I installed rate-mirrors and ran the

I also reinstalled my archlinux-keyring and my endeavouros-keyring

looks like pacman -Syyu is working now.

Thanks everyone!

I have been a loyal endevouros user for the past couple years and this is the first real issue I have run into. and it got solved in a couple hours. Cheers!


Great that you got it solved! :+1:
In fact reflector should have been installed, so it should’ve been visible in Welcome…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.