System unbootable after recent update

Hi, I just updated my system and now it will not boot. There are quite a few services that are failing.

Ignore the GPU error, this has been there for a long time and doesn’t prevent boot. I can access the TTY, but networking is completely broken.

Has anyone else had similar issues with this update? I had ran yay -Syu twice, first time it was successful but then there was about 30 packages to update when I ran again. After I installed that, none of my programs would open, and upon rebooting I got that screen.

Thank you

Yes, just updated on my laptop and the exact same thing happened …

Looks like it is a faulty update, another dependency was pushed to stable too late:

chroot into system and update, there is a fix already (util-linux, util-linux-libs)


The “fix” is pushing a release candidate version of “util-linux-libs” clearly marked as “new upstream pre-release, testing only!” to stable.

I think someone did an oopsie with this one …


seems like a better temporary fix would be downgrading the glib2 package using sudo pacman -U /var/cache/pacman/pkg/glib2-2.80.0-1

1 Like

works for me so far :stuck_out_tongue:

Yeah it works, but I don’t get why they are pushing a release candidate for this to stable …

I don’t think this was supposed to happen like this.

Thank you, my system is booting again :slight_smile: booted into live environment and chrooted to my system then ran an update and all working

1 Like

Yeah, this was not supposed to happend the way it did:

I get error when trying this in tty4. sudo pacman -U /var/cache/pacman/pkg/glib2-2.80.0-1 could not find or read package. Must not be in cache for me. any other way to downgrade? glib2

Yes, by downloading the older version directly from the website/repo.

One second, let me find it.

Here you go:

Essentially, it is the same command, but you link to a file on the repos rather than your system.

glib is found here:

As usual, make sure to read and understand the instructions before doing anything.

1 Like

Wow, very nice, downgrade worked for glib2, but after reboot, I have same screen in gnome ‘oh no oops!’ dialog, but my browser opens up because its set to auto-open. So I have to control+alt+f4 to open tty4 console. Any other recommendations on downgrades, system is up to date except glib2. Thanks for you help

1 Like

You’re welcome.

Did you set glib2 to ignore? Otherwise, when you reboot (since you said the system is up-to-date), you’ll run into the same issue.

Apart from ignoring the package, there would be nothing else you need to do. Just look out for a future update to glib2 (that is, one newer than the problematic one).

1 Like

I’m actually not sure what all this means. Were you able to log in?

Correct, set glib2 to ignore. Will wait for future update. Thank You!

1 Like

One more thing here, actually.

glib2 is a core package, which means it should not be ignored indefinitely. As such, you would try to see if the problematic version begins working as expected, even if you don’t get a new update for it.

In the case of glib2, it gets updated pretty much every two weeks, so it shouldn’t be a problem. So, this note of caution is for other packages that may only get updated once or twice a year.

I had same behavior after glib2 downgrade. So I went to recent updates and looked through the 2024-03-23 updates and reinstalled mutter because it looked like gnome window manager issue and reinstalled glib2 to latest update and it works again. Thanks again

System Details Report

Report details

  • Date generated: 2024-03-23 23:22:53

Hardware Information:

  • Hardware Model: Dell Inc. Inspiron 5567
  • Memory: 8.0 GiB
  • Processor: Intel® Core™ i7-7500U × 4
  • Graphics: Intel® HD Graphics 620 (KBL GT2)
  • Disk Capacity: 1.0 TB

Software Information:

  • Firmware Version: 1.5.0
  • OS Name: EndeavourOS
  • OS Build: 2023.05.28
  • OS Type: 64-bit
  • GNOME Version: 46
  • Windowing System: Wayland
  • Kernel Version: Linux 6.8.1-arch1-1

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.