System stuck with NetworkManager

Apologize in advance for not well written post.

Hello, newbie here. I am using USB wifi adapter and chipset is rtl8812bu.
When I tried to install EOS, it stucked on NetworkManager when booting.

So I unplugged adapter and it worked again.
After installing EOS in offline mode, I plugged adapter again, connect to wifi and OS freezed. I opened tty and typed simple commands but nothing responed, just blinking curor.
In Linux mint, I manually installed driver and it worked very well. I think it might be a driver issue. Is there a way to uninstall prebuilt driver and install driver manually?

This may be the driver you need:

You should be able to install it with yay. Maybe someone with more experience with realtek drivers can chime in?

Thank you for quick answer.
Unfortunately, it didn’t work. Systen freezed again. It works again if I unplug the adapter.

If its posilbe to invest in a wifi adapter that has built-in support in the Linux kernel, here is a list of supported chipsets:

You may also benefit from this page:

I deleted everything in /lib/modules/6.7.1-arch1-1/kernel/net/wireless and reinstall driver manually, and it works! I don’t know in depth, but it might be because of the kernel.

I see you got it working. :+1:

Hopefully you will not need to manually reinstall the driver each time the kernel updates. :thinking:

That’s why I researched the problem further and found a better way.

  1. Unplug your device before booting.
  2. Disable NetworkManager with these commands to prevent the kernel from freezing.
systemctl stop NetworkManager
systemctl disable NetworkManager
  1. Reconnect your device and check which driver your device is using. See
  2. Stop and blacklist your driver. Open /etc/modprobe.d and create a new .conf file and add the line blacklist your-driver.
rmmod your-driver
cd /etc/modprobe.d/.
nano blacklist.conf

# Now add the following line and save.
# blacklist your-driver
  1. Install the correct driver. This step will vary depending on your driver.
  2. Enable ‘NetworkManager’ again.
systemctl enable NetworkManager
systemctl start NetworkManager

And the kernel shouldn’t freeze again.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.