System rapidly slows down when adapter is plugged in

i have quite a new lenovo laptot, but it slows down everytime it is plugged into charger?

when unplugged, everything works absolutely fine, but with adapter it laggs and do all sorts of nonsense.

i tried updates, downgrades, lts kernel and all that, but nothing helped.

any idea how troubleshoot it?

Try removing the battery from the laptop. While it is out, plug in the adapter and boot it up to see if you observe the slow behavior or the normal behavior.

Please be more specific. What precisely does “nonsense” entail?

Check the power profile when your laptop is plugged it? Did you somehow set it to power-saving mode when it is on the adapter?

by nonsense i mean it lags. I type something in pycharm and it takes second to appear, cursor jump. I want to move a file in dophin and it stops for couple of seconds… then continues… even when i am logging in, then i type my password, i type 5 letters and it stops at first… waits… then it finishes the rest…

it is basically very unresponsive and quite a terrible experience to us

power profile on batter - adapter unplugged

adapter plugged

There are some people who seem to have reported more or less similar issues:

Perhaps have a look at the lenovo forums?

Only trying to help.

what is quite interesting is that it started when i did system upgrade a week ago… till that time it worked ok. the system upgraded tons of packages… broke my vpn and other stuff… but i could fix them all, except this one…

unfortunatelly i dont know the process of downgrading to a particular point in time when it worked… and i dont even think it would work…

now it seems like the only solutiion is to reinstall OS

This is almost never the solution.

Also, downgrading, despite it being discouraged, is actually quite easy. Links below, but again, it is DISCOURAGED. It’s your system, though. Do as you please.

Can you access the BIOS and check the settings for adaptive thermal management? If I’m not mistaken, lenovo laptops have different thermal management modes/schemes for AC and battery. You can try to make sure that the setting is optimized for maximum performance for AC.

Unless you’re using a snapshot, doing this would require figuring out the exact package that is causing the issue.

Also check the journal entries when the lagging occurs. There might be some useful information there.